summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-30 14:52:31 +0200
committerSam James <sam@gentoo.org>2020-09-16 02:03:09 +0000
commit3de9f762ff59d19bd3afdba7d0abc63372eb8dcf (patch)
treeafb11edd76b8f1f381c29a56a7ce9ae881ef8c70 /dev-cpp/popl
parentapp-benchmarks/siege: forward-port LDFLAGS changes (diff)
downloadgentoo-3de9f762ff59d19bd3afdba7d0abc63372eb8dcf.tar.gz
gentoo-3de9f762ff59d19bd3afdba7d0abc63372eb8dcf.tar.bz2
gentoo-3de9f762ff59d19bd3afdba7d0abc63372eb8dcf.zip
dev-cpp/popl: port to EAPI 7
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/popl')
-rw-r--r--dev-cpp/popl/popl-1.2.0.ebuild12
-rw-r--r--dev-cpp/popl/popl-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/dev-cpp/popl/popl-1.2.0.ebuild b/dev-cpp/popl/popl-1.2.0.ebuild
index 39652fbae851..f58b83ff2381 100644
--- a/dev-cpp/popl/popl-1.2.0.ebuild
+++ b/dev-cpp/popl/popl-1.2.0.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit cmake
DESCRIPTION="Header-only C++ program options parser library"
HOMEPAGE="https://github.com/badaix/popl"
if [[ ${PV} == *9999 ]] ; then
- inherit cmake-utils git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/badaix/popl.git"
EGIT_BRANCH="develop"
else
- inherit cmake-utils
SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
KEYWORDS="~amd64 ~x86"
fi
@@ -25,5 +25,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-cpp/popl/popl-9999.ebuild b/dev-cpp/popl/popl-9999.ebuild
index 39652fbae851..f58b83ff2381 100644
--- a/dev-cpp/popl/popl-9999.ebuild
+++ b/dev-cpp/popl/popl-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit cmake
DESCRIPTION="Header-only C++ program options parser library"
HOMEPAGE="https://github.com/badaix/popl"
if [[ ${PV} == *9999 ]] ; then
- inherit cmake-utils git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/badaix/popl.git"
EGIT_BRANCH="develop"
else
- inherit cmake-utils
SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
KEYWORDS="~amd64 ~x86"
fi
@@ -25,5 +25,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}