summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-10-01 13:48:51 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 13:02:30 +0300
commit884d96bcab917d649a1aaccee846fe070633881a (patch)
treef70fe9c2da1759a1a75ad3f35102ab61f9cc1300 /dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild
parentapp-crypt/rotix: remove unused patch (diff)
downloadgentoo-884d96bcab917d649a1aaccee846fe070633881a.tar.gz
gentoo-884d96bcab917d649a1aaccee846fe070633881a.tar.bz2
gentoo-884d96bcab917d649a1aaccee846fe070633881a.zip
dev-cpp/prometheus-cpp: Version bump to 0.10.0
Closes: https://bugs.gentoo.org/746026 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17736 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild')
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild
new file mode 100644
index 000000000000..3cd755921597
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/cppcodec
+ net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ )
+
+ cmake_src_configure
+}