summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-11-14 10:07:08 +0000
committerMarek Szuba <marecki@gentoo.org>2022-11-14 11:05:55 +0000
commitdece9829f016de521df9b9c06e57883ec488cf1f (patch)
treeae0e894f38fb0a6b80a7ca9eafe66346a0aa1124 /dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
parentdev-python/pyopencl: add 2022.2.4 (diff)
downloadgentoo-dece9829f016de521df9b9c06e57883ec488cf1f.tar.gz
gentoo-dece9829f016de521df9b9c06e57883ec488cf1f.tar.bz2
gentoo-dece9829f016de521df9b9c06e57883ec488cf1f.zip
dev-cpp/prometheus-cpp: add 1.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild')
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
new file mode 100644
index 000000000000..6239a46b04df
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ -DGENERATE_PKGCONFIG=ON
+ -DRUN_IWYU=OFF
+ )
+
+ cmake_src_configure
+}