summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-12 16:05:33 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-12 16:05:59 -0700
commit0d601682798febc90360cc8c9ab9e24053b1815d (patch)
tree01d5430f1c64b69eee38a230bf347d5b2e247d0b /dev-cpp/random123/random123-1.09-r1.ebuild
parentwww-servers/apache: Added "h2c" directive to http2 config. (diff)
downloadgentoo-0d601682798febc90360cc8c9ab9e24053b1815d.tar.gz
gentoo-0d601682798febc90360cc8c9ab9e24053b1815d.tar.bz2
gentoo-0d601682798febc90360cc8c9ab9e24053b1815d.zip
dev-cpp/random123: install missing header
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-cpp/random123/random123-1.09-r1.ebuild')
-rw-r--r--dev-cpp/random123/random123-1.09-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/random123/random123-1.09-r1.ebuild b/dev-cpp/random123/random123-1.09-r1.ebuild
new file mode 100644
index 000000000000..26c96c47cc63
--- /dev/null
+++ b/dev-cpp/random123/random123-1.09-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="library of counter-based random number generators (CBRNGs)"
+HOMEPAGE="https://www.deshawresearch.com/resources_random123.html"
+MY_P="${P^r}"
+SRC_URI="https://www.deshawresearch.com/downloads/download_${PN}.cgi/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/include/Random123
+ doins -r include/Random123/. examples/uniform.hpp
+}