summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-06-08 13:31:13 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-06-08 13:58:48 +0200
commitc7b5fe8078297dd0a5b68fc79f06b5ef535f8d7c (patch)
treeb103780a45322f95a6eb019c04f4d0ac196b6156 /dev-cpp/scitokens-cpp
parentdev-libs/libmacaroons: new package, add 0.3.0 (diff)
downloadgentoo-c7b5fe8078297dd0a5b68fc79f06b5ef535f8d7c.tar.gz
gentoo-c7b5fe8078297dd0a5b68fc79f06b5ef535f8d7c.tar.bz2
gentoo-c7b5fe8078297dd0a5b68fc79f06b5ef535f8d7c.zip
dev-cpp/scitokens-cpp: new package, add 1.0.1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-cpp/scitokens-cpp')
-rw-r--r--dev-cpp/scitokens-cpp/Manifest1
-rw-r--r--dev-cpp/scitokens-cpp/metadata.xml18
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/scitokens-cpp/Manifest b/dev-cpp/scitokens-cpp/Manifest
new file mode 100644
index 000000000000..3c5aca40b9d3
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/Manifest
@@ -0,0 +1 @@
+DIST scitokens-cpp-1.0.1.tar.gz 309430 BLAKE2B cfb0a25bde68076334d37d0b47adcb2f1b794bf60330f612c3bfbe2588e420a2b427e9e9916ee14c2c348ed4448d781fad2068d35560b45740b81144aa12e6a6 SHA512 592d8c473ecdeed49c5552239d98e4da57313c8914b3c97c74a6bc4b1f4929b4490a33695e741972a8c83f6097d644fc4df94b3ca54d811c64dcf542b6467ea9
diff --git a/dev-cpp/scitokens-cpp/metadata.xml b/dev-cpp/scitokens-cpp/metadata.xml
new file mode 100644
index 000000000000..f04332ace873
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amadio@gentoo.org</email>
+ <name>Guilherme Amadio</name>
+ </maintainer>
+ <longdescription lang="en">
+ SciTokens provide a token format for distributed authorization. The tokens are
+ self-describing, can be verified in a distributed fashion (no need to contact
+ the issuer to determine if the token is valid). This is convenient for a
+ federated environment where several otherwise-independent storage endpoints
+ want to delegate trust for an issuer for managing a storage allocation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">scitokens/scitokens-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
new file mode 100644
index 000000000000..e6a43dfceee1
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ implementation of the SciTokens library with a C library interface"
+HOMEPAGE="https://github.com/scitokens/scitokens-cpp"
+SRC_URI="https://github.com/scitokens/scitokens-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test" # testing requires network
+
+DEPEND="
+ dev-db/sqlite
+ dev-libs/openssl:0=
+ net-misc/curl:0=
+ kernel_linux? ( sys-apps/util-linux )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSCITOKENS_BUILD_UNITTESTS=$(usex test)
+ -DSCITOKENS_EXTERNAL_GTEST=1
+ )
+ cmake_src_configure
+}