summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-03-18 18:02:57 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-03-18 18:03:21 +0100
commit88dd71d503544ff3d11c6653ff23b7a938430ac7 (patch)
tree8f3575d78f481a9f9b70b6fae8c959a0a3654d60 /dev-cpp/tbb/files
parentnet-vpn/tor: Security bump (diff)
downloadgentoo-88dd71d503544ff3d11c6653ff23b7a938430ac7.tar.gz
gentoo-88dd71d503544ff3d11c6653ff23b7a938430ac7.tar.bz2
gentoo-88dd71d503544ff3d11c6653ff23b7a938430ac7.zip
dev-cpp/tbb: version bump to 2020.1
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-cpp/tbb/files')
-rw-r--r--dev-cpp/tbb/files/tbb-2020.1-makefile-debug.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-cpp/tbb/files/tbb-2020.1-makefile-debug.patch b/dev-cpp/tbb/files/tbb-2020.1-makefile-debug.patch
new file mode 100644
index 000000000000..b4313b375f59
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-2020.1-makefile-debug.patch
@@ -0,0 +1,62 @@
+--- a/Makefile 2020-01-21 12:26:46.000000000 +0100
++++ b/Makefile 2020-03-18 16:21:37.589262099 +0100
+@@ -26,29 +26,29 @@
+ all: tbb tbbmalloc tbbproxy test examples
+
+ tbb: mkdir
+- $(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.tbb cfg=release
++ $(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.tbb cfg=$(cfg)
+
+ tbbmalloc: mkdir
+- $(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.tbbmalloc cfg=release malloc
++ $(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.tbbmalloc cfg=$(cfg) malloc
+
+ tbbproxy: mkdir
+- $(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.tbbproxy cfg=release tbbproxy
++ $(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.tbbproxy cfg=$(cfg) tbbproxy
+
+ tbbbind: mkdir
+- $(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.tbbbind cfg=release tbbbind
++ $(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.tbbbind cfg=$(cfg) tbbbind
+
+ test: tbb tbbmalloc $(if $(use_proxy),tbbproxy)
+- -$(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.tbbmalloc cfg=release malloc_test
+- -$(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.test cfg=release
++ -$(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.tbbmalloc cfg=$(cfg) malloc_test
++ -$(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.test cfg=$(cfg)
+
+ rml: mkdir
+- $(MAKE) -C "$(work_dir)_release" -r -f $(tbb_root)/build/Makefile.rml cfg=release
++ $(MAKE) -C "$(work_dir)_$(cfg)" -r -f $(tbb_root)/build/Makefile.rml cfg=$(cfg)
+
+ examples: tbb tbbmalloc
+- $(MAKE) -C examples -r -f Makefile tbb_root=.. release test
++ $(MAKE) -C examples -r -f Makefile tbb_root=.. $(cfg) test
+
+ python: tbb
+- $(MAKE) -C "$(work_dir)_release" -rf $(tbb_root)/python/Makefile install
++ $(MAKE) -C "$(work_dir)_$(cfg)" -rf $(tbb_root)/python/Makefile install
+
+ doxygen:
+ doxygen Doxyfile
+@@ -56,16 +56,16 @@
+ .PHONY: clean clean_examples mkdir info
+
+ clean: clean_examples
+- $(shell $(RM) $(work_dir)_release$(SLASH)*.* >$(NUL) 2>$(NUL))
+- $(shell $(RD) $(work_dir)_release >$(NUL) 2>$(NUL))
++ $(shell $(RM) $(work_dir)_$(cfg)$(SLASH)*.* >$(NUL) 2>$(NUL))
++ $(shell $(RD) $(work_dir)_$(cfg) >$(NUL) 2>$(NUL))
+ @echo clean done
+
+ clean_examples:
+ $(shell $(MAKE) -s -i -r -C examples -f Makefile tbb_root=.. clean >$(NUL) 2>$(NUL))
+
+ mkdir:
+- $(shell $(MD) "$(work_dir)_release" >$(NUL) 2>$(NUL))
+- @echo Created the $(work_dir)_release directory
++ $(shell $(MD) "$(work_dir)_$(cfg)" >$(NUL) 2>$(NUL))
++ @echo Created the $(work_dir)_$(cfg) directory
+
+ info:
+ @echo OS: $(tbb_os)