summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-04 04:34:28 +0000
committerSam James <sam@gentoo.org>2021-12-04 04:34:28 +0000
commit9214e7e9cc6ea662076a535f9eac9338b03429ed (patch)
tree8fe1deb3f52018fc4b0c9aa9c32c90a244f8d9b8 /dev-cpp/termcolor
parentdev-cpp/elfio: initial import (diff)
downloadgentoo-9214e7e9cc6ea662076a535f9eac9338b03429ed.tar.gz
gentoo-9214e7e9cc6ea662076a535f9eac9338b03429ed.tar.bz2
gentoo-9214e7e9cc6ea662076a535f9eac9338b03429ed.zip
dev-cpp/termcolor: initial import
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/termcolor')
-rw-r--r--dev-cpp/termcolor/Manifest1
-rw-r--r--dev-cpp/termcolor/metadata.xml11
-rw-r--r--dev-cpp/termcolor/termcolor-2.0.0.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/termcolor/Manifest b/dev-cpp/termcolor/Manifest
new file mode 100644
index 000000000000..49924bd31aaa
--- /dev/null
+++ b/dev-cpp/termcolor/Manifest
@@ -0,0 +1 @@
+DIST termcolor-2.0.0.tar.gz 88582 BLAKE2B 3e7a4a99af3586fff103d0de0601e019881745e2921b4750dbf476439138a71120b6513a287c5fe26fd96a9c6115cb82295810d9bea11d0992f48fcd5d0a8d18 SHA512 72dead77fb9f3ff79432b1659b57c3d961a57b46305937acd0c221f5abb016f609dfaf7a9bf508bd7a073338ee604cf55f9915c8e8a76ddfaf6c68bc031e37f9
diff --git a/dev-cpp/termcolor/metadata.xml b/dev-cpp/termcolor/metadata.xml
new file mode 100644
index 000000000000..07725c8b4ff7
--- /dev/null
+++ b/dev-cpp/termcolor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ikalnytskyi/termcolor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/termcolor/termcolor-2.0.0.ebuild b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
new file mode 100644
index 000000000000..2b522f5ede05
--- /dev/null
+++ b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ library for printing colored messages to the terminal"
+HOMEPAGE="https://github.com/ikalnytskyi/termcolor https://termcolor.readthedocs.io"
+SRC_URI="https://github.com/ikalnytskyi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# It's just a visual test, nothing automated / no way to detect failure in an ebuild.
+RESTRICT="!test? ( test ) test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTERMCOLOR_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}