summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-14 22:16:41 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-14 22:16:41 +0100
commite047bed35a8f1071bdd77c503d573e0cb3c82264 (patch)
tree68b1d7e6bc3af5a7af13061c31dffa96f80f1e54 /dev-cpp/tree/files/tree-2.81-test.patch
parentmedia-plugins/kodi-visualization-projectm: Cleanup old versions (diff)
downloadgentoo-e047bed35a8f1071bdd77c503d573e0cb3c82264.tar.gz
gentoo-e047bed35a8f1071bdd77c503d573e0cb3c82264.tar.bz2
gentoo-e047bed35a8f1071bdd77c503d573e0cb3c82264.zip
dev-cpp/tree: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/tree/files/tree-2.81-test.patch')
-rw-r--r--dev-cpp/tree/files/tree-2.81-test.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/tree/files/tree-2.81-test.patch b/dev-cpp/tree/files/tree-2.81-test.patch
new file mode 100644
index 000000000000..c9e675dc7953
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.81-test.patch
@@ -0,0 +1,36 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,13 +1,6 @@
+-
+-%.o: %.cc
+- g++ -c -I. $^
+-
+-test1: test1.o
+- g++ -o test1 test1.o
+-
+-run_tests: test1 test1.req
+- ./test1 > test1.res
+- @diff test1.res test1.req
++check: test_tree
++ ./test_tree > mytest.output && \
++ diff -Nu test_tree.output mytest.output
+ @echo "*** All tests OK ***"
+
+ clean:
+--- a/test_tree.output
++++ b/test_tree.output
+@@ -1,3 +1,8 @@
++-----
++hi
++ 1
++ 0
++-----
+ empty tree to begin with:
+ 0
+ 'more text' is sibling 2 in its sibling range
+@@ -309,3 +314,5 @@
+ D
+ I
+ -----
++G
++H