summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-11-27 10:47:10 -0500
committerCraig Andrews <candrews@gentoo.org>2017-11-27 10:51:24 -0500
commitefbab7f140baa39e108375ff9c1535c86a112b3d (patch)
tree0af727bcefaf3132d9a53fcc0e6650e11c9cd264 /dev-cpp/waylandpp/waylandpp-0.1.5.ebuild
parentdev-vcs/git-tools: drop eutils (diff)
downloadgentoo-efbab7f140baa39e108375ff9c1535c86a112b3d.tar.gz
gentoo-efbab7f140baa39e108375ff9c1535c86a112b3d.tar.bz2
gentoo-efbab7f140baa39e108375ff9c1535c86a112b3d.zip
dev-cpp/waylandpp: Version bump 0.1.5
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-cpp/waylandpp/waylandpp-0.1.5.ebuild')
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.5.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.5.ebuild
new file mode 100644
index 000000000000..e8100f35eb98
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.1.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}