summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-08-21 22:55:55 -0400
committerCraig Andrews <candrews@gentoo.org>2017-08-22 16:01:45 -0400
commit8aefce0d6bf9f411298063a200654b39115500b3 (patch)
tree62391539a83d9c01ae619ecb83c0eb76b13cad5e /dev-cpp/waylandpp/waylandpp-9999.ebuild
parentapp-arch/unp: [QA] Use relative symlink target(s) (diff)
downloadgentoo-8aefce0d6bf9f411298063a200654b39115500b3.tar.gz
gentoo-8aefce0d6bf9f411298063a200654b39115500b3.tar.bz2
gentoo-8aefce0d6bf9f411298063a200654b39115500b3.zip
dev-cpp/waylandpp: Wayland C++ bindings
Gentoo-bug: 628562 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: #5504
Diffstat (limited to 'dev-cpp/waylandpp/waylandpp-9999.ebuild')
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
new file mode 100644
index 000000000000..a85f301bf9fd
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib scons-utils toolchain-funcs versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/waylandpp-${PV}"
+fi
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+RDEPEND="${COMMON_DEPEND}"
+
+src_compile() {
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" escons
+ if use doc; then
+ doxygen || die "error making docs"
+ fi
+}
+
+src_install() {
+ PREFIX="${D%/}/usr" scons install
+ # fix multilib-strict QA failures
+ mv "${ED%/}"/usr/{lib,$(get_libdir)} || die
+ if use doc; then
+ doman doc/man/man3/*.3
+ HTML_DOCS="doc/html" einstalldocs
+ fi
+}