summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-17 22:48:52 +0200
committerJohannes Huber <johu@gentoo.org>2015-08-17 22:49:26 +0200
commit91028219f1913c17244ab624698b2ed0bd9d4ab5 (patch)
tree234e70066380b13bbfd084cbef0f5f2c88efc880 /dev-cpp/websocketpp/websocketpp-0.6.0.ebuild
parentsci-geosciences/xtide: version bump to 2.13.2 (diff)
downloadgentoo-91028219f1913c17244ab624698b2ed0bd9d4ab5.tar.gz
gentoo-91028219f1913c17244ab624698b2ed0bd9d4ab5.tar.bz2
gentoo-91028219f1913c17244ab624698b2ed0bd9d4ab5.zip
dev-cpp/websocketpp: Version bump 0.6.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.6.0.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.6.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.6.0.ebuild
new file mode 100644
index 000000000000..003a6a251fd3
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# tests no-op
+RESTRICT="test"
+
+src_configure() {
+ # Disable EXAMPLES as compilation is broken upstream
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ $(cmake-utils_use_enable !boost CPP11)
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}