summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-07-19 17:32:55 -0500
committerSam James <sam@gentoo.org>2020-07-27 02:18:14 +0000
commitdf25aa0798f692e44a99922e9a27d013fafc0bd7 (patch)
treec8b246543c2361c96ec10c19bbc2135a200679a6 /dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild
parentdev-cpp/yaml-cpp: Revbump to add security patch (diff)
downloadgentoo-df25aa0798f692e44a99922e9a27d013fafc0bd7.tar.gz
gentoo-df25aa0798f692e44a99922e9a27d013fafc0bd7.tar.bz2
gentoo-df25aa0798f692e44a99922e9a27d013fafc0bd7.zip
dev-cpp/yaml-cpp: Cleanup <0.6.3-r2
Bug: https://bugs.gentoo.org/626662 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16622 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild')
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild
deleted file mode 100644
index 925e955fe1d7..000000000000
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.6.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-DESCRIPTION="YAML parser and emitter in C++"
-HOMEPAGE="https://github.com/jbeder/yaml-cpp"
-SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/0.6"
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-CVE-2017-5950.patch"
- "${FILESDIR}/${P}-unbundle-gtest.patch"
-)
-
-src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
- -DYAML_CPP_BUILD_TESTS=$(usex test)
- )
- cmake-multilib_src_configure
-}