summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-05 10:43:42 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-05 11:19:05 +0200
commit10e3bb9d02fae277221023e09074a2ee1605228f (patch)
tree21b318e13f90155fcdd8c662aa446b557b013092 /dev-cpp
parentdev-cpp/threadpool: Modernize to EAPI=6 (diff)
downloadgentoo-10e3bb9d02fae277221023e09074a2ee1605228f.tar.gz
gentoo-10e3bb9d02fae277221023e09074a2ee1605228f.tar.bz2
gentoo-10e3bb9d02fae277221023e09074a2ee1605228f.zip
dev-cpp/threadpool: Remove deprecated ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/threadpool/threadpool-0.2.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-cpp/threadpool/threadpool-0.2.5.ebuild b/dev-cpp/threadpool/threadpool-0.2.5.ebuild
deleted file mode 100644
index 6b82416dade7..000000000000
--- a/dev-cpp/threadpool/threadpool-0.2.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit base
-
-DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
-HOMEPAGE="http://threadpool.sourceforge.net/"
-MY_PV=${PV//./_}
-MY_P=${PN}-${MY_PV}
-SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
-SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
- doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="dev-libs/boost"
-
-S="${WORKDIR}/${MY_P}-src/${PN}"
-
-PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
-
-src_prepare() {
- base_src_prepare
-}
-
-src_compile() {
- # Do nothing
- # The makefile just builds the documentation again
- # Not even any install targets
- :
-}
-
-src_install() {
- insinto /usr/include/
- doins -r boost
- dodoc README TODO CHANGE_LOG
- if use doc; then
- dohtml -r "${WORKDIR}"/"${MY_P}"-doc/
- fi
-}