summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 21:42:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 23:19:54 +0100
commit123eca67c41a657baef5709ec6fa9ff2dcf5403f (patch)
treebc858221c4841f2aa55967485b7f415f2950da25 /dev-cpp
parentdev-cpp/libcmis: 0.6.2 version bump, SLOT=0 and bump subslot to 0.6 (diff)
downloadgentoo-123eca67c41a657baef5709ec6fa9ff2dcf5403f.tar.gz
gentoo-123eca67c41a657baef5709ec6fa9ff2dcf5403f.tar.bz2
gentoo-123eca67c41a657baef5709ec6fa9ff2dcf5403f.zip
dev-cpp/libcmis: Fix build with dev-libs/libxml2-2.12.0
Closes: https://bugs.gentoo.org/917523 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libcmis/files/libcmis-0.6.2-libxml2-2.12.patch26
-rw-r--r--dev-cpp/libcmis/libcmis-0.6.2.ebuild3
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/libcmis/files/libcmis-0.6.2-libxml2-2.12.patch b/dev-cpp/libcmis/files/libcmis-0.6.2-libxml2-2.12.patch
new file mode 100644
index 000000000000..a00fb863dcb5
--- /dev/null
+++ b/dev-cpp/libcmis/files/libcmis-0.6.2-libxml2-2.12.patch
@@ -0,0 +1,26 @@
+From 72618e63433c7243e4d9e79a638f19a09402eecc Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 21 Nov 2023 23:10:07 +0100
+Subject: [PATCH] Fix build with libxml2-2.12 (missing include)
+
+See also: https://github.com/tdf/libcmis/issues/51
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ inc/libcmis/xml-utils.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/inc/libcmis/xml-utils.hxx b/inc/libcmis/xml-utils.hxx
+index 929385e..9bd99ae 100644
+--- a/inc/libcmis/xml-utils.hxx
++++ b/inc/libcmis/xml-utils.hxx
+@@ -34,6 +34,7 @@
+ #include <string>
+
+ #include <boost/date_time.hpp>
++#include <libxml/parser.h>
+ #include <libxml/tree.h>
+ #include <libxml/xpathInternals.h>
+ #include <libxml/xmlwriter.h>
+--
+2.43.0
+
diff --git a/dev-cpp/libcmis/libcmis-0.6.2.ebuild b/dev-cpp/libcmis/libcmis-0.6.2.ebuild
index 1d4b60e4cd0e..6c8abf60f12d 100644
--- a/dev-cpp/libcmis/libcmis-0.6.2.ebuild
+++ b/dev-cpp/libcmis/libcmis-0.6.2.ebuild
@@ -41,6 +41,9 @@ BDEPEND="
)
"
+# https://github.com/tdf/libcmis/pull/52
+PATCHES=( "${FILESDIR}/${P}-libxml2-2.12.patch" ) # bug 917523
+
src_prepare() {
default
eautoreconf