summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-13 23:22:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-14 01:46:21 -0400
commit16dbaad166c01dc830f0d42c4d915c1f5b18f775 (patch)
treee2973ff2abef089a27dd8cec0ac34cf47c504b5f /dev-cpp
parentdev-cpp/sol2: new package 3.2.2 (diff)
downloadgentoo-16dbaad166c01dc830f0d42c4d915c1f5b18f775.tar.gz
gentoo-16dbaad166c01dc830f0d42c4d915c1f5b18f775.tar.bz2
gentoo-16dbaad166c01dc830f0d42c4d915c1f5b18f775.zip
dev-cpp/sol2: use smaller gcc11 patch
Upstream's commit that fixes this has too many unrelated changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sol2/Manifest1
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch10
-rw-r--r--dev-cpp/sol2/sol2-3.2.2.ebuild7
3 files changed, 12 insertions, 6 deletions
diff --git a/dev-cpp/sol2/Manifest b/dev-cpp/sol2/Manifest
index b298932cab93..88055ed75b0e 100644
--- a/dev-cpp/sol2/Manifest
+++ b/dev-cpp/sol2/Manifest
@@ -1,2 +1 @@
-DIST sol2-3.2.2-gcc11.patch 24788 BLAKE2B bc50d638c6414d86af7a744c26c3eae05400d593caeca725d3d15e81a76bcb22817994cdbb884c795aaa157e8c3de0753e38c6352e57dc081e001e8e245aa9a7 SHA512 98bb29cf7e89306ed7e9d350dc924b5fa10d51cb7ff4eb3ac873775d17c3b8849a37d6c1566fe9eb18222b524d648b4268d513fb0a2e7d272a4a6032eda10930
DIST sol2-3.2.2.tar.gz 8531029 BLAKE2B 65fd220f5109e4917d06d5ef906ceccb7e292276f69bd49dfd826089a77e566af1811fdf660ffbfbd2437dca4b86ef5c4790dace9029805926e1ee0445b2e965 SHA512 e5a739b37aea7150f141f6a003c2689dd33155feed5bb3cf2569abbfe9f0062eacdaaf346be523d627f0e491b35e68822c80e1117fa09ece8c9d8d5af09fdbec
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch b/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
new file mode 100644
index 000000000000..cc8c6bb1b4f7
--- /dev/null
+++ b/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
@@ -0,0 +1,10 @@
+Add missing include needed for tests (and possibly consumers) with gcc11.
+
+Fixed upstream in:
+https://github.com/ThePhD/sol2/commit/e5e6466e09b632677d24a8f204d6a0ea0a8862b1
+--- a/include/sol/stack_core.hpp
++++ b/include/sol/stack_core.hpp
+@@ -42,2 +42,3 @@
+ #include <string>
++#include <limits>
+ #include <algorithm>
diff --git a/dev-cpp/sol2/sol2-3.2.2.ebuild b/dev-cpp/sol2/sol2-3.2.2.ebuild
index 4a8b270ac71e..8af75c6deec7 100644
--- a/dev-cpp/sol2/sol2-3.2.2.ebuild
+++ b/dev-cpp/sol2/sol2-3.2.2.ebuild
@@ -8,10 +8,7 @@ inherit cmake lua
DESCRIPTION="Header-only C++ <-> Lua API wrapper"
HOMEPAGE="https://github.com/ThePhD/sol2"
-SRC_URI="
- https://github.com/ThePhD/sol2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/ThePhD/sol2/commit/e5e6466e09b632677d24a8f204d6a0ea0a8862b1.patch -> ${P}-gcc11.patch
-"
+SRC_URI="https://github.com/ThePhD/sol2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -33,7 +30,7 @@ BDEPEND="
"
PATCHES=(
- "${DISTDIR}"/${P}-gcc11.patch
+ "${FILESDIR}"/${P}-gcc11.patch
"${FILESDIR}"/${P}-luajit-pkgconf.patch
"${FILESDIR}"/${P}-catch-depend.patch
)