summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-20 20:09:22 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-20 20:09:55 +0200
commit1cf8d3728c30733339deec965087135dbafe8525 (patch)
tree5bebe558b9efbe4210891ee7beb3cc06df2167e3 /dev-cpp
parentwww-client/chromium: fix build with GCC on ARM64 (diff)
downloadgentoo-1cf8d3728c30733339deec965087135dbafe8525.tar.gz
gentoo-1cf8d3728c30733339deec965087135dbafe8525.tar.bz2
gentoo-1cf8d3728c30733339deec965087135dbafe8525.zip
dev-cpp/xsimd: new package, add 11.0.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/xsimd/Manifest1
-rw-r--r--dev-cpp/xsimd/metadata.xml11
-rw-r--r--dev-cpp/xsimd/xsimd-11.0.0.ebuild52
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-cpp/xsimd/Manifest b/dev-cpp/xsimd/Manifest
new file mode 100644
index 000000000000..53212822b10f
--- /dev/null
+++ b/dev-cpp/xsimd/Manifest
@@ -0,0 +1 @@
+DIST xsimd-11.0.0.tar.gz 218589 BLAKE2B ce0021f51d541d8c713645c84c38df2cf0e769fba191ba1ef030da682aa6176467cc1cc2722feac4bc0d3f931e1611d16349818eb9b4e9e1803d39f0985ecfbd SHA512 75927ab1369aa8eb321d4a2e425f14d977cd1a5792d13a8ca5a393b030fce7a5ce00492a5145a3fbedd29c3ad38556d5a4b2242534eb76dc5164b7cef4f8406b
diff --git a/dev-cpp/xsimd/metadata.xml b/dev-cpp/xsimd/metadata.xml
new file mode 100644
index 000000000000..22b20250f0c2
--- /dev/null
+++ b/dev-cpp/xsimd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xtensor-stack/xsimd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/xsimd/xsimd-11.0.0.ebuild b/dev-cpp/xsimd/xsimd-11.0.0.ebuild
new file mode 100644
index 000000000000..79ea0b73bf17
--- /dev/null
+++ b/dev-cpp/xsimd/xsimd-11.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrappers for SIMD intrinsics"
+HOMEPAGE="https://github.com/xtensor-stack/xsimd"
+SRC_URI="https://github.com/xtensor-stack/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/breathe
+ dev-python/sphinx
+ )
+ test? ( dev-cpp/doctest )"
+
+src_prepare() {
+ sed -i \
+ -e '/fPIC/d' \
+ test/CMakeLists.txt \
+ || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && emake -C docs html
+}
+
+src_install() {
+ cmake_src_install
+ if use doc; then
+ dodoc -r docs/build/html
+ fi
+}