summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-20 12:03:12 +0200
committerMarek Szuba <marecki@gentoo.org>2021-09-20 12:03:12 +0200
commit2d38f4c4ae36b0b861deeb27df482471efd6afff (patch)
treedfad2fbfd0cdef07a52b434e044a7ac484b02140 /dev-cpp
parentdev-cpp/benchmark: add 1.6.0 (diff)
downloadgentoo-2d38f4c4ae36b0b861deeb27df482471efd6afff.tar.gz
gentoo-2d38f4c4ae36b0b861deeb27df482471efd6afff.tar.bz2
gentoo-2d38f4c4ae36b0b861deeb27df482471efd6afff.zip
dev-cpp/benchmark: drop 1.5.3, 1.5.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.3.ebuild28
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.5.ebuild28
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.3.ebuild b/dev-cpp/benchmark/benchmark-1.5.3.ebuild
deleted file mode 100644
index 1463b00dc41b..000000000000
--- a/dev-cpp/benchmark/benchmark-1.5.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~x86"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}
diff --git a/dev-cpp/benchmark/benchmark-1.5.5.ebuild b/dev-cpp/benchmark/benchmark-1.5.5.ebuild
deleted file mode 100644
index fc246f0b80a0..000000000000
--- a/dev-cpp/benchmark/benchmark-1.5.5.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~riscv ~x86"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}