summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-09-26 23:45:21 -0600
committerTim Harder <radhermit@gentoo.org>2019-09-26 23:48:37 -0600
commit2f3fc667b7590223e897bac98c5bcc70a44051d0 (patch)
tree5c39c89d1ad15bc00b93085792abcddd991bb4b5 /dev-cpp
parentapp-text/nfoview: clean old ebuilds (diff)
downloadgentoo-2f3fc667b7590223e897bac98c5bcc70a44051d0.tar.gz
gentoo-2f3fc667b7590223e897bac98c5bcc70a44051d0.tar.bz2
gentoo-2f3fc667b7590223e897bac98c5bcc70a44051d0.zip
dev-cpp/nlohmann_json: version bump to 3.7.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/Manifest1
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 486ceb43b520..0f21d8807bcc 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,2 +1,3 @@
DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
+DIST nlohmann_json-3.7.0.tar.gz 118868542 BLAKE2B 25191628b737ea5614de85d0fcb4425fcb2d37e6890626e6ba22949430a1c5f827ff17d1cd8245c8e98d0deda617d8268c55caff3017a6b4a2f730e524599311 SHA512 35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
new file mode 100644
index 000000000000..ed480ec910fb
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSON_BuildTests=$(usex test)
+ -DJSON_MultipleHeaders=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r doc/html
+}