summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-05 13:31:17 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-05 13:31:40 +0100
commit390bd29b869a5daff23213223bd33a474d6743f5 (patch)
treec22965c75ec16a875f34ae36964e93e4d0eaead4 /dev-cpp
parentsys-devel/binutils: stable 2.32-r2 on ia64, bug #699180 (diff)
downloadgentoo-390bd29b869a5daff23213223bd33a474d6743f5.tar.gz
gentoo-390bd29b869a5daff23213223bd33a474d6743f5.tar.bz2
gentoo-390bd29b869a5daff23213223bd33a474d6743f5.zip
dev-cpp/lucene++: Migrate to cmake eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/lucene++-3.0.7-r2.ebuild b/dev-cpp/lucene++/lucene++-3.0.7-r2.ebuild
new file mode 100644
index 000000000000..84363e8ff778
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake_src_configure
+}