summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-06-23 11:34:27 -0400
committerCraig Andrews <candrews@gentoo.org>2020-06-23 11:34:44 -0400
commit57ebbe280ce99f7f5346b6507bc7dc4dcdeae41f (patch)
tree61e307453c3a102e3e5f20600e2e161fb293a3f0 /dev-cpp
parentkde-plasma/powerdevil: Drop 5.19.1 (diff)
downloadgentoo-57ebbe280ce99f7f5346b6507bc7dc4dcdeae41f.tar.gz
gentoo-57ebbe280ce99f7f5346b6507bc7dc4dcdeae41f.tar.bz2
gentoo-57ebbe280ce99f7f5346b6507bc7dc4dcdeae41f.zip
dev-cpp/waylandpp: Fix ‘runtime_error’ is not a member of ‘std’
Closes: https://bugs.gentoo.org/729200 Package-Manager: Portage-2.3.102, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/waylandpp/files/waylandpp-0.2.7-fix-std-runtime_error.patch25
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.7.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/files/waylandpp-0.2.7-fix-std-runtime_error.patch b/dev-cpp/waylandpp/files/waylandpp-0.2.7-fix-std-runtime_error.patch
new file mode 100644
index 000000000000..41e71eb237bc
--- /dev/null
+++ b/dev-cpp/waylandpp/files/waylandpp-0.2.7-fix-std-runtime_error.patch
@@ -0,0 +1,25 @@
+From 695c0881101435a57d24c84d04cbcb79eec49903 Mon Sep 17 00:00:00 2001
+From: Rechi <Rechi@users.noreply.github.com>
+Date: Sat, 18 Jan 2020 23:37:46 +0100
+Subject: [PATCH] [fix] add missing stdexcept include after 2d834a6
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+fixes error: ‘runtime_error’ is not a member of ‘std’
+---
+ include/wayland-util.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/wayland-util.hpp b/include/wayland-util.hpp
+index 9cf5d04..1609651 100644
+--- a/include/wayland-util.hpp
++++ b/include/wayland-util.hpp
+@@ -28,6 +28,7 @@
+
+ #include <algorithm>
+ #include <memory>
++#include <stdexcept>
+ #include <string>
+ #include <typeinfo>
+ #include <utility>
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
index 6fda559666cb..f25c7dccb2b2 100644
--- a/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.2.7.ebuild
@@ -32,6 +32,10 @@ DEPEND="${RDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-std-runtime_error.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc)