summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-05 02:41:47 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-05 03:15:01 -0500
commit5b02217d233557707ecdd488e9c575464f2d43d8 (patch)
treef62c57e5ff47296511c9d3372a3ef5f0abe31f9d /dev-cpp
parentdev-ruby/rmagick: add 5.4.0 (diff)
downloadgentoo-5b02217d233557707ecdd488e9c575464f2d43d8.tar.gz
gentoo-5b02217d233557707ecdd488e9c575464f2d43d8.tar.bz2
gentoo-5b02217d233557707ecdd488e9c575464f2d43d8.zip
dev-cpp/cli11: add 2.4.0
wrt dev-cpp/catch restriction removal, this version adds logic to work with either v2 or v3. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cli11/Manifest1
-rw-r--r--dev-cpp/cli11/cli11-2.4.0.ebuild59
-rw-r--r--dev-cpp/cli11/files/cli11-2.4.0-cstdint.patch7
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/cli11/Manifest b/dev-cpp/cli11/Manifest
index a76342ad6441..3875f8b5eebd 100644
--- a/dev-cpp/cli11/Manifest
+++ b/dev-cpp/cli11/Manifest
@@ -1 +1,2 @@
DIST cli11-2.3.2.tar.gz 303507 BLAKE2B 68a1ca97fb55a4329f7d56a7d661f71f356bebcb0878421bccb18093aab171cff963f4e3e8f47b95cac4947ebbd7c7d6c853cc28e404c07091685ba1e99ac8d3 SHA512 f48b289d52034c47b90db58c035a123b464bed488cf31bcdbe10a692214a5c05e62b99d6fb7c4b065f42df862ecf3813f11dd533b3697939d761e99d2b89c2ec
+DIST cli11-2.4.0.tar.gz 338628 BLAKE2B 8e9a58c81be34826ef455851b618d18fcf7f75f654539f4f961e63b1be364b656133163b6e1c00ccf1f67e4a45772556570d6a70f8845a69b13665da29b3bafa SHA512 21c6e7861c5b5481079f78fd1585c77c7c73dd8f06a58a673922ee12fa0ffd2ba6c485de427a4e4ee3e5d710b8dc9483e70da0dc2a67c46d3fd77ebdfe300f79
diff --git a/dev-cpp/cli11/cli11-2.4.0.ebuild b/dev-cpp/cli11/cli11-2.4.0.ebuild
new file mode 100644
index 000000000000..552deb9ddd53
--- /dev/null
+++ b/dev-cpp/cli11/cli11-2.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Command line parser for C++11"
+HOMEPAGE="https://cliutils.github.io/CLI11/book/"
+SRC_URI="
+ https://github.com/CLIUtils/CLI11/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN^^}-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-cpp/catch:0
+ dev-libs/boost
+ )
+"
+BDEPEND="
+ doc? (
+ app-text/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-cstdint.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLI11_BUILD_DOCS=$(usex doc)
+ -DCLI11_BUILD_EXAMPLES=no
+ -DCLI11_BUILD_TESTS=$(usex test)
+ $(usev test -DCLI11_BOOST=yes)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile all $(usev doc docs)
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md book/{chapters,code,*.md} )
+ cmake_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/docs/html
+}
diff --git a/dev-cpp/cli11/files/cli11-2.4.0-cstdint.patch b/dev-cpp/cli11/files/cli11-2.4.0-cstdint.patch
new file mode 100644
index 000000000000..d6e99a4417e1
--- /dev/null
+++ b/dev-cpp/cli11/files/cli11-2.4.0-cstdint.patch
@@ -0,0 +1,7 @@
+https://github.com/CLIUtils/CLI11/issues/993
+--- a/include/CLI/impl/StringTools_inl.hpp
++++ b/include/CLI/impl/StringTools_inl.hpp
+@@ -12,2 +12,3 @@
+ // [CLI11:public_includes:set]
++#include <cstdint>
+ #include <string>