summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-09-04 10:46:45 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-09-04 11:13:22 -0500
commit5ce30845bee0de57f6f41d66fb5e4d01a2b7ed51 (patch)
tree64f1daec98268aa9079d194d743003d8586d796b /dev-cpp
parentsci-libs/dealii: update live ebuild (diff)
downloadgentoo-5ce30845bee0de57f6f41d66fb5e4d01a2b7ed51.tar.gz
gentoo-5ce30845bee0de57f6f41d66fb5e4d01a2b7ed51.tar.bz2
gentoo-5ce30845bee0de57f6f41d66fb5e4d01a2b7ed51.zip
dev-cpp/cpp-taskflow: version bump to 2.6.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest1
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
index 4c62f183ab25..3af8545a82b1 100644
--- a/dev-cpp/cpp-taskflow/Manifest
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -1 +1,2 @@
DIST cpp-taskflow-2.4.0.tar.gz 76993334 BLAKE2B 8f257165ab72dbe6c1cf6a86886669008e9f16f1dfd4871defc452bdb9dfa3e45ab9bfbbdc874b4ba566a2a7d8984a666ce2933b2c6d2215467f7fbfa03ac520 SHA512 dd6c7500e39d7058871280d12e120bd28d9609e5289f1d7851b3b59e2c1bfe74d3040d902bd5b26895e558b563c8abad878e7bc343e199e7356940c02a64217f
+DIST cpp-taskflow-2.6.0.tar.gz 68626469 BLAKE2B d85b1615be47c1e98e613e7875424892613205a0cc3f380f7d6fd0521045c5750441e9267382ec5282299e4074a7b85f442e53f38a2f12aff7d3d925a94b8773 SHA512 43b023c7d744ae1e0baf6f504f32da481e950ec5cc34fe5511e4bbb8905203e4726917ee103b1c02544a75c6216c2ca481034be810b61a35511a3d7a2b278133
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
new file mode 100644
index 000000000000..aba4692adef3
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/taskflow-${PV}"
+
+PATCHES=(
+)
+
+HTML_DOCS=( docs/. )
+
+src_prepare() {
+ default
+
+ # fix library directoy
+ sed -i "s#/lib#/$(get_libdir)#g" CMakeLists.txt || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # FIXME: enable CUDA and TESTS via use flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_TESTS=OFF
+ -DTF_BUILD_EXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}