summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-12 23:56:48 +0200
committerDavid Seifert <soap@gentoo.org>2023-08-12 23:56:48 +0200
commit6894aea248f27601c324d124b26e31902d146239 (patch)
tree2dafdd0d7cf22303a7eef29cff3c49bce1a3770f /dev-cpp
parentdev-python/littleutils: Stabilize 0.2.2-r1 hppa, #912139 (diff)
downloadgentoo-6894aea248f27601c324d124b26e31902d146239.tar.gz
gentoo-6894aea248f27601c324d124b26e31902d146239.tar.bz2
gentoo-6894aea248f27601c324d124b26e31902d146239.zip
dev-cpp/catch: drop 3.0.1
Closes: https://bugs.gentoo.org/865207 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-3.0.1.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index 91edcf74d9b9..c0bbb7ca91e0 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,4 +1,3 @@
DIST Catch-1.12.2.tar.gz 377265 BLAKE2B bc27b4daee950f8fb93d65f3aed032e72bc856ee27a8dc28c35b89e33f414d68ba4cf00951e476688eddf9e4c0514036bd6916fa6cfa9e3359e6c625984f114f SHA512 ed963cdca9fe307ee02928677f81cafcb41cd607faaa315182fdf898d0f2aa28f0be2141bd642f46fdfac400c38f6d065e00a595a1e5879fe2335c4a3851e844
DIST Catch2-2.13.8.tar.gz 661711 BLAKE2B 973cc73c1d158140645003e76c0baf85a65252041fdcae3c6ecb1857021f2d24d8e879fec5f00368f4f458e69b450603a1613ac587417725980f1dbfe3ff2e65 SHA512 68a45efa47beb3c85d2d7b8a8eba89b8ec1664b4a72bb223227fef1632778aeaf5cf5cc09f40e47aef50426c8661c7d6a69c2dab0b88fbbf7d9a6b2974d6e32e
-DIST Catch2-3.0.1.tar.gz 1020413 BLAKE2B 91c207bb67b9d97191fcd5b3f50df66c7d671aabb4deb989b6d838eba205e981d6dc51fb82d7c13d65751746215abc769a0274da9ee0512a53c4afbeb3540efb SHA512 065094c19cdf98b40f96a390e887542f895495562a91cdc28d68ce03690866d846ec87d320405312a2b97eacaa5351d3e55f0012bb9de40073c8d4444d82b0a1
DIST Catch2-3.4.0.tar.gz 1112790 BLAKE2B 0e3680b6e9d01d7661243097ec4a8e20d06a145acfe381cedc8eb2507c5df1bfb2b2907a9ae2771ffd94b66a0aa8f746aae4419ed4f469bea27c3bfca366ca3e SHA512 3b452378201ac53c9ffba7801231aa3b32c5fb496f01d670fcee25baf95f405e565ae2aafba49ea5694f906fc61a8b04592c68b9fb12839767070587a48c89fa
diff --git a/dev-cpp/catch/catch-3.0.1.ebuild b/dev-cpp/catch/catch-3.0.1.ebuild
deleted file mode 100644
index 04724eae0130..000000000000
--- a/dev-cpp/catch/catch-3.0.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake python-any-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
-else
- MY_P=${PN^}2-${PV}
- SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/catchorg/Catch2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.1-gcc13.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCATCH_DEVELOPMENT_BUILD=ON
- -DCATCH_ENABLE_WERROR=OFF
- -DCATCH_BUILD_TESTING=$(usex test)
- )
- use test && mycmakeargs+=(
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
-
- cmake_src_configure
-}