summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-22 00:44:25 +0000
committerSam James <sam@gentoo.org>2021-01-22 01:39:56 +0000
commit707c081dc1c2346b7b87f8073d000b531590b84d (patch)
treea8b8cfc86c6070fda00a1fe2cc3343e3b7d4b8b1 /dev-cpp
parentgames-strategy/ja2-stracciatella: bump to 0.17.0 (diff)
downloadgentoo-707c081dc1c2346b7b87f8073d000b531590b84d.tar.gz
gentoo-707c081dc1c2346b7b87f8073d000b531590b84d.tar.bz2
gentoo-707c081dc1c2346b7b87f8073d000b531590b84d.zip
dev-cpp/string-theory: run tests
We now conditionally build tests too. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/string-theory/string-theory-3.3.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/dev-cpp/string-theory/string-theory-3.3.ebuild b/dev-cpp/string-theory/string-theory-3.3.ebuild
index a8bb093a351a..82fb3efef9de 100644
--- a/dev-cpp/string-theory/string-theory-3.3.ebuild
+++ b/dev-cpp/string-theory/string-theory-3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,3 +13,18 @@ S="${WORKDIR}/string_theory-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DST_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./st_gtests || die
+}