summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-29 10:59:46 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-29 11:23:13 -0400
commit757b8d594a52713cad06bb40387712e3b55bbaa9 (patch)
treeb86c62f185085b823eebd03664ad1286cb9aec73 /dev-cpp
parentdev-python/pyx: DEPEND on latex-base always (diff)
downloadgentoo-757b8d594a52713cad06bb40387712e3b55bbaa9.tar.gz
gentoo-757b8d594a52713cad06bb40387712e3b55bbaa9.tar.bz2
gentoo-757b8d594a52713cad06bb40387712e3b55bbaa9.zip
dev-cpp/robin-hood-hashing: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/robin-hood-hashing/Manifest1
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild18
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5.ebuild23
3 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/robin-hood-hashing/Manifest b/dev-cpp/robin-hood-hashing/Manifest
index 721c9b323e71..11af6af61850 100644
--- a/dev-cpp/robin-hood-hashing/Manifest
+++ b/dev-cpp/robin-hood-hashing/Manifest
@@ -1,2 +1 @@
-DIST robin-hood-hashing-3.11.2.tar.gz 170488 BLAKE2B 5fb688f5e21f989456e139b64447393816593ad2a1c3537d067d8ea1717aceaa879e27616657354f62e1466ca491f9d302448a73cddb53c7156a623eb375016b SHA512 5d55f054e29ae34d410eb0103f9f0aa1faf47e313b9f089c73b9c26fd9bedf132f6bb13b4bcd2664309c32fe7e859e346d0a6e7ab7f46b294f9b8db207577795
DIST robin-hood-hashing-3.11.5.tar.gz 177134 BLAKE2B b114c1d68ff2eae4cdb526e67def750a11056c2b5c400eab0870fda7c81dde5cf3bb168ea13ed3d34f2e57edffea5c58cb79ffb5328ecf839c723c71f54676d3 SHA512 5f73e089b1e8ec41a9bedded22bc64a789d3a3d04873a2ad9f8cc2970797a473b0f4d3436c2324b3ced85a0d983998a75b1dfaf2b7f3b77235b29806ff2fd489
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
deleted file mode 100644
index 1a32ac192607..000000000000
--- a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.2.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
-HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
-
-LICENSE="MIT"
-SLOT="0"
-
-src_install() {
- insinto /usr/include
- doins src/include/robin_hood.h
-}
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5.ebuild
deleted file mode 100644
index 6e42350ec553..000000000000
--- a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
-HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
-
-LICENSE="MIT"
-SLOT="0"
-
-src_configure() {
- local mycmakeargs=(
- -DRH_STANDALONE_PROJECT=OFF
- -DCMAKE_INSTALL_LIBDIR="${ESYSROOT}/usr/share/"
- )
- cmake_src_configure
-}