summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 03:25:16 +0000
committerSam James <sam@gentoo.org>2023-12-28 03:25:16 +0000
commit78194f2bd185ceb1d2491ab423614a726adb1287 (patch)
treeaa26b4403a7467d464102f35ab5b9538132640a8 /dev-cpp
parentapp-emacs/treesit-auto: drop 0.6.9, 1.0.0 (diff)
downloadgentoo-78194f2bd185ceb1d2491ab423614a726adb1287.tar.gz
gentoo-78194f2bd185ceb1d2491ab423614a726adb1287.tar.bz2
gentoo-78194f2bd185ceb1d2491ab423614a726adb1287.zip
dev-cpp/elfio: drop 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/elfio/Manifest1
-rw-r--r--dev-cpp/elfio/elfio-3.11.ebuild32
-rw-r--r--dev-cpp/elfio/files/elfio-3.11-system-gtest.patch33
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-cpp/elfio/Manifest b/dev-cpp/elfio/Manifest
index 0e76e209c613..01708ff43ab6 100644
--- a/dev-cpp/elfio/Manifest
+++ b/dev-cpp/elfio/Manifest
@@ -1,2 +1 @@
-DIST elfio-3.11.tar.gz 4150700 BLAKE2B 2e0270384f1fdbc8f8374c1a42b5bd0c6ba6faa8c8a7125063b682cd9808fbb3f330e2a0fa4646c8828f6d276ad8f92e36b69ab7916c3bd2b1b2ecad6708fcc1 SHA512 3a254aad62e707f2809e2997998aab6a9794d70791dc535a6de90bad3e9de3cbcc4f8e7787067ca7cd47ce2dc71cf52809747267bc36cfb08369b49a6b92cf5e
DIST elfio-3.12.tar.gz 4150640 BLAKE2B aba7c4a9c254384b3babcf740883e45b8b531ecde3bc12f3cb811ac63c1469d0d53d9bb259120d92bacad7289d811429785a784667d4632c3acc49f2c3a475e4 SHA512 f5c8bc6cc98da845f6c011fc85b98476935c5d20d72b36bff5ad2472434494115ee7c06cfa37152c528e5931c39fe3cc084bfc8e6952b2c3e8f24b8601ae212f
diff --git a/dev-cpp/elfio/elfio-3.11.ebuild b/dev-cpp/elfio/elfio-3.11.ebuild
deleted file mode 100644
index 0c82a247cdd9..000000000000
--- a/dev-cpp/elfio/elfio-3.11.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="ELF reader/producer header-only C++ library"
-HOMEPAGE="https://github.com/serge1/ELFIO"
-SRC_URI="https://github.com/serge1/${PN}/archive/Release_${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN^^}-Release_${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.11-system-gtest.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DFETCHCONTENT_FULLY_DISCONNECTED=ON
- -DELFIO_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch b/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch
deleted file mode 100644
index 2110086c69d6..000000000000
--- a/dev-cpp/elfio/files/elfio-3.11-system-gtest.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/serge1/ELFIO/pull/113
-
-From 4c47fd4c783f286a73605e43e362f1e14b0296a9 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 19 Nov 2022 02:56:22 +0000
-Subject: [PATCH] tests: allow using system gtest copy
-
-Distributions often do builds with no network access available
-for both security reasons and also to ensure reproducibility.
-
-This change tells CMake to query the system for a copy of gtest,
-but if it's not available, it'll fall back to downloading via
-FetchContent.
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -3,6 +3,7 @@ include(FetchContent)
- FetchContent_Declare(
- googletest
- URL https://github.com/google/googletest/archive/9a32aee22d771387c494be2d8519fbdf46a713b2.zip
-+ FIND_PACKAGE_ARGS NAMES GTest
- )
-
- # For Windows: Prevent overriding the parent project's compiler/linker settings
-@@ -44,7 +45,8 @@ target_link_libraries(
- ELFIOTest
- PRIVATE
- elfio::elfio
-- gtest_main)
-+ gtest_main
-+ GTest::gtest_main)
-
- add_test(
- NAME