summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-27 09:59:12 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-27 10:19:08 +0200
commit8e30c9b1f86cf50a8e84e8042956c3568111cccf (patch)
tree448f824c634a011978b64043bf5b3cbe305d1efe /dev-cpp
parentdev-cpp/libjson-rpc-cpp: Restrict tests to -j1 (diff)
downloadgentoo-8e30c9b1f86cf50a8e84e8042956c3568111cccf.tar.gz
gentoo-8e30c9b1f86cf50a8e84e8042956c3568111cccf.tar.bz2
gentoo-8e30c9b1f86cf50a8e84e8042956c3568111cccf.zip
dev-cpp/catch: Split the live ebuild to upst branches
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild34
-rw-r--r--dev-cpp/catch/catch-9999.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
new file mode 100644
index 000000000000..8949a527ca65
--- /dev/null
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
+EGIT_BRANCH=master
+inherit cmake-utils git-r3
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI=""
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
+
+src_test() {
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index 41195675fe3b..5ca782d46a21 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=6
EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
+EGIT_BRANCH=catch2
inherit cmake-utils git-r3
DESCRIPTION="Modern C++ header-only framework for unit-tests"