summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-06 20:27:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-28 16:02:38 +0300
commit95f28daeb7b8e4cd7ed75cfa564a00fcdd8cccc8 (patch)
tree6c376f2301aea41b21dcd34a33f378f92b8289ea /dev-cpp
parentdev-cpp/aixlog: drop old (diff)
downloadgentoo-95f28daeb7b8e4cd7ed75cfa564a00fcdd8cccc8.tar.gz
gentoo-95f28daeb7b8e4cd7ed75cfa564a00fcdd8cccc8.tar.bz2
gentoo-95f28daeb7b8e4cd7ed75cfa564a00fcdd8cccc8.zip
dev-cpp/aixlog: sync live
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/aixlog/aixlog-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-cpp/aixlog/aixlog-9999.ebuild b/dev-cpp/aixlog/aixlog-9999.ebuild
index 1246304bfa01..b1164d6bbd11 100644
--- a/dev-cpp/aixlog/aixlog-9999.ebuild
+++ b/dev-cpp/aixlog/aixlog-9999.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit cmake
DESCRIPTION="Header-only C++ logging library"
HOMEPAGE="https://github.com/badaix/aixlog"
if [[ ${PV} == *9999 ]] ; then
- inherit cmake-utils git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
EGIT_BRANCH="develop"
else
- inherit cmake-utils
-
- SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
+ SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,5 +24,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}