summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-02 22:30:51 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-02 22:30:51 +0100
commit962d55e3c6489f692ca2a0c5cd1ea37df8a8a755 (patch)
tree5babd0e84048debbde3cf0aab5e21efa9abbfda0 /dev-cpp
parentsci-libs/cfitsio: typo fix (diff)
downloadgentoo-962d55e3c6489f692ca2a0c5cd1ea37df8a8a755.tar.gz
gentoo-962d55e3c6489f692ca2a0c5cd1ea37df8a8a755.tar.bz2
gentoo-962d55e3c6489f692ca2a0c5cd1ea37df8a8a755.zip
dev-cpp/nlohmann_json: Minor style clean up
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index dda1074ac3b3..9e63f828a377 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -7,8 +7,9 @@ inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+SRC_URI="
+ https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
S="${WORKDIR}/json-${PV}"
LICENSE="MIT"
@@ -20,7 +21,7 @@ IUSE="doc test"
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog.md README.md )
@@ -31,20 +32,19 @@ src_configure() {
-DJSON_BuildTests=$(usex test)
)
- if use test ; then
- # Define test data directory here to avoid unused var QA warning
- # #747826
- mycmakeargs+=(
- -DJSON_TestDataDirectory="${S}/json_test_data"
- )
- fi
+ # Define test data directory here to avoid unused var QA warning, bug #747826
+ use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
cmake_src_configure
}
src_compile() {
cmake_src_compile
- use doc && emake -C doc
+
+ if use doc; then
+ emake -C doc
+ HTML_DOCS=( doc/html/. )
+ fi
}
src_test() {
@@ -58,8 +58,3 @@ src_test() {
cmake_src_test
}
-
-src_install() {
- cmake_src_install
- use doc && dodoc -r doc/html
-}