summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-18 13:25:32 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-18 18:28:03 +0100
commit976adb420ddcbf63886f648100828b65953e40ad (patch)
tree16a87402fd26383d65d8f2c81c9a63bc727cb21e /dev-cpp
parentdev-cpp/mm-common: use ${EPYTHON}, not python3 (diff)
downloadgentoo-976adb420ddcbf63886f648100828b65953e40ad.tar.gz
gentoo-976adb420ddcbf63886f648100828b65953e40ad.tar.bz2
gentoo-976adb420ddcbf63886f648100828b65953e40ad.zip
dev-cpp/pangomm: use ${EPYTHON}, not python3
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/770895 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pangomm/pangomm-2.42.2.ebuild5
-rw-r--r--dev-cpp/pangomm/pangomm-2.48.0.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/pangomm/pangomm-2.42.2.ebuild b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
index 34eee793e8e6..d0a2f770d9af 100644
--- a/dev-cpp/pangomm/pangomm-2.42.2.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org meson multilib-minimal
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org"
@@ -26,6 +28,7 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
)
+ ${PYTHON_DEPS}
"
multilib_src_configure() {
diff --git a/dev-cpp/pangomm/pangomm-2.48.0.ebuild b/dev-cpp/pangomm/pangomm-2.48.0.ebuild
index 7a3b8eba6959..924043617bfa 100644
--- a/dev-cpp/pangomm/pangomm-2.48.0.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.48.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org meson multilib-minimal
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org"
@@ -26,6 +28,7 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
)
+ ${PYTHON_DEPS}
"
multilib_src_configure() {