summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-29 14:47:36 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-29 14:59:07 -0600
commita14e62c7082d739a51c160a78201ab20a65a5c02 (patch)
tree260ecd6a231660d42956205f6791b3cecc540ae0 /dev-cpp
parentx11-wm/mutter: remove old (diff)
downloadgentoo-a14e62c7082d739a51c160a78201ab20a65a5c02.tar.gz
gentoo-a14e62c7082d739a51c160a78201ab20a65a5c02.tar.bz2
gentoo-a14e62c7082d739a51c160a78201ab20a65a5c02.zip
dev-cpp/nlohmann_json: initial import
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/Manifest1
-rw-r--r--dev-cpp/nlohmann_json/metadata.xml11
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
new file mode 100644
index 000000000000..e4b3cb520a16
--- /dev/null
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -0,0 +1 @@
+DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
diff --git a/dev-cpp/nlohmann_json/metadata.xml b/dev-cpp/nlohmann_json/metadata.xml
new file mode 100644
index 000000000000..eb8bff7e3814
--- /dev/null
+++ b/dev-cpp/nlohmann_json/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ <name>Gentoo Video project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nlohmann/json</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild
new file mode 100644
index 000000000000..56411b042378
--- /dev/null
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="JSON for Modern C++"
+HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
+SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( ChangeLog.md README.md )
+
+S=${WORKDIR}/json-${PV}
+
+src_compile() {
+ meson_src_compile
+ use doc && emake -C doc
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ meson_src_install
+ use doc && dodoc -r doc/html
+}