summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-10-02 21:43:17 -0400
committerGuilherme Amadio <amadio@gentoo.org>2019-10-03 11:31:43 +0200
commita1ddeefb53647830f2c1b781c51487eecd290d4a (patch)
treef8639492c96d7d9b21d2f3c16905467d80b9d7e2 /dev-cpp
parentdev-lang/ruby: ppc64 stable wrt bug #696004 (diff)
downloadgentoo-a1ddeefb53647830f2c1b781c51487eecd290d4a.tar.gz
gentoo-a1ddeefb53647830f2c1b781c51487eecd290d4a.tar.bz2
gentoo-a1ddeefb53647830f2c1b781c51487eecd290d4a.zip
dev-cpp/tbb: Fix building with clang
Prevent "clang++" from being inadvertently matched to "*g++*" in a case statement. Closes: https://bugs.gentoo.org/662990 Closes: https://github.com/gentoo/gentoo/pull/13129 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/tbb-2019.8.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-cpp/tbb/tbb-2019.8.ebuild b/dev-cpp/tbb/tbb-2019.8.ebuild
index fd77782aba4e..b01745011776 100644
--- a/dev-cpp/tbb/tbb-2019.8.ebuild
+++ b/dev-cpp/tbb/tbb-2019.8.ebuild
@@ -80,9 +80,9 @@ local_src_compile() {
esac
case "$(tc-getCXX)" in
+ *clang*) comp="clang" ;;
*g++*) comp="gcc" ;;
*ic*c) comp="icc" ;;
- *clang*) comp="clang" ;;
*) die "compiler $(tc-getCXX) not supported by build system" ;;
esac