summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-30 23:32:33 +0100
committerMarek Szuba <marecki@gentoo.org>2023-03-30 23:41:41 +0100
commita7cede31f5a70fc4a10614eba4cd28a54dd33ca5 (patch)
tree668db55488f8ec8e805d2037079a66fb41876f86 /dev-cpp
parentdev-libs/msgpack: add 6.0.0 (diff)
downloadgentoo-a7cede31f5a70fc4a10614eba4cd28a54dd33ca5.tar.gz
gentoo-a7cede31f5a70fc4a10614eba4cd28a54dd33ca5.tar.bz2
gentoo-a7cede31f5a70fc4a10614eba4cd28a54dd33ca5.zip
dev-cpp/msgpack-cxx: add 6.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/msgpack-cxx/Manifest1
-rw-r--r--dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-cpp/msgpack-cxx/Manifest b/dev-cpp/msgpack-cxx/Manifest
index 9f955877b62c..4f749820ecf6 100644
--- a/dev-cpp/msgpack-cxx/Manifest
+++ b/dev-cpp/msgpack-cxx/Manifest
@@ -1 +1,2 @@
DIST msgpack-cxx-5.0.0.tar.gz 476103 BLAKE2B e631a47e8d39b6ad9c2dd5e782fbbd5044c177e18c619fb52d1293e2c5f2ea7e766e7b26ce6cac36a2ff98217143e12456e0541992afb4f78597ffd3852f2acf SHA512 5ee0237eb1bf05bd4becad32ab145a8f0654f8f0e2e3452331ed3df088cda03ee4cdf1557ba867447e3e18baed924c105c76934f7009dac98b6dc69282c39d0c
+DIST msgpack-cxx-6.0.0.tar.gz 476132 BLAKE2B 89b6505511bd8f6994a2e61661c7a33bd1aa68804c081ec2fcaf074f845caf4338ac362916af9fb0bab7285b0d0508c74b229316fa75ef8083546ac84c4ca95d SHA512 90f89216676af5a656d570fbff5a716d1177fa1941b0a928b2da20e0b6cd6d0ca880b7369e085dbbca944499c05694a73df919042d8cd78498ed4b34b77a0e9d
diff --git a/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild b/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild
new file mode 100644
index 000000000000..8e3609f7d111
--- /dev/null
+++ b/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="MessagePack for C++"
+HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+SRC_URI="https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+boost doc examples test"
+
+REQUIRED_USE="test? ( boost )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="boost? ( dev-libs/boost[context] )
+ !<dev-libs/msgpack-5.0.0"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )
+ test? ( sys-libs/zlib )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMSGPACK_BUILD_EXAMPLES=OFF
+ -DMSGPACK_CXX17=ON
+ -DMSGPACK_BUILD_TESTS="$(usex test)"
+ -DMSGPACK_USE_BOOST="$(usex boost)"
+ -DMSGPACK_USE_X3_PARSE="$(usex boost)"
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ cmake_build doxygen
+ fi
+}
+
+src_install() {
+ if use doc; then
+ local HTML_DOCS=( "${BUILD_DIR}"/doc_cpp/html/. )
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cmake_src_install
+}