summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-30 21:19:39 +0000
committerSam James <sam@gentoo.org>2020-10-08 20:16:08 +0000
commitadb952e04174d932eb899f64892b2ff5ce0463fc (patch)
treec24c7ab8b831f4092024525228659d5a255c68db /dev-cpp
parentdev-util/catalyst: Finish removing IUSE=system-bootloader (diff)
downloadgentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.tar.gz
gentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.tar.bz2
gentoo-adb952e04174d932eb899f64892b2ff5ce0463fc.zip
dev-cpp/robin-map: new package (fast robinhood hashing in c++)
new dependency for media-libs/openimageio Closes: https://bugs.gentoo.org/678292 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/robin-map/Manifest1
-rw-r--r--dev-cpp/robin-map/metadata.xml12
-rw-r--r--dev-cpp/robin-map/robin-map-0.6.3.ebuild20
-rw-r--r--dev-cpp/robin-map/robin-map-9999.ebuild20
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/robin-map/Manifest b/dev-cpp/robin-map/Manifest
new file mode 100644
index 000000000000..fbc684a36779
--- /dev/null
+++ b/dev-cpp/robin-map/Manifest
@@ -0,0 +1 @@
+DIST robin-map-0.6.3.tar.gz 64506 BLAKE2B 46a2b5b47346016695db0c49f73cfbf8530b7db0a31527030eb00f3b6f0695325ab6fe16de1e60d6b1d0793818bdd1e31e50117f2e2e4c50154f65b38ac66d84 SHA512 485557f300d33bda62bb8accdf246819ee8ffe956bc022e7ddca54ff6ad1a9fdb8db8d80690add3ef238e834d1eb8e2905920cb0a0674e7df010f6946d01297b
diff --git a/dev-cpp/robin-map/metadata.xml b/dev-cpp/robin-map/metadata.xml
new file mode 100644
index 000000000000..8238cc0570ce
--- /dev/null
+++ b/dev-cpp/robin-map/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-cpp/robin-map/robin-map-0.6.3.ebuild b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
new file mode 100644
index 000000000000..99255a6ea187
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/dev-cpp/robin-map/robin-map-9999.ebuild b/dev-cpp/robin-map/robin-map-9999.ebuild
new file mode 100644
index 000000000000..99255a6ea187
--- /dev/null
+++ b/dev-cpp/robin-map/robin-map-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ fast hash map and hash set using robin hood hashing"
+HOMEPAGE="https://github.com/Tessil/robin-map"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Tessil/robin-map"
+else
+ SRC_URI="https://github.com/Tessil/robin-map/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"