summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 15:28:59 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 15:28:59 +0300
commitba7c80df35ba31d7a7d51deccaaa71f9c8d47f9e (patch)
tree8155215abaec2fe08dbcf1637177d08f9f78f2c6 /dev-cpp
parentmedia-tv/kodi: remove libressl support (diff)
downloadgentoo-ba7c80df35ba31d7a7d51deccaaa71f9c8d47f9e.tar.gz
gentoo-ba7c80df35ba31d7a7d51deccaaa71f9c8d47f9e.tar.bz2
gentoo-ba7c80df35ba31d7a7d51deccaaa71f9c8d47f9e.zip
dev-cpp/asio: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/asio-1.17.0.ebuild7
-rw-r--r--dev-cpp/asio/asio-1.18.1.ebuild5
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-cpp/asio/asio-1.17.0.ebuild b/dev-cpp/asio/asio-1.17.0.ebuild
index e81139edfc90..434556c8ecbb 100644
--- a/dev-cpp/asio/asio-1.17.0.ebuild
+++ b/dev-cpp/asio/asio-1.17.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="doc examples libressl ssl test"
+IUSE="doc examples ssl test"
RESTRICT="!test? ( test )"
# test searches for libssl during ./configure, and REQUIRED_USE is easier than
# patching configure to not search for it with USE=-ssl
@@ -18,8 +18,7 @@ REQUIRED_USE="test? ( ssl )"
RDEPEND="dev-libs/boost
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)"
DEPEND="${RDEPEND}"
diff --git a/dev-cpp/asio/asio-1.18.1.ebuild b/dev-cpp/asio/asio-1.18.1.ebuild
index 55fc4cb2fe52..82d648ca221a 100644
--- a/dev-cpp/asio/asio-1.18.1.ebuild
+++ b/dev-cpp/asio/asio-1.18.1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc examples libressl ssl test"
+IUSE="doc examples ssl test"
RESTRICT="!test? ( test )"
# test searches for libssl during ./configure, and REQUIRED_USE is easier than
# patching configure to not search for it with USE=-ssl
@@ -18,8 +18,7 @@ REQUIRED_USE="test? ( ssl )"
RDEPEND="dev-libs/boost:=
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)"
DEPEND="${RDEPEND}"