summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-07-10 11:40:28 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-10 11:40:28 +0200
commitcd1a85e41bd9b3a3068fb6dc2f3fc350d1b88167 (patch)
tree7b09994fd495b43ffcfae14e4849b5d790ac81c8 /dev-cpp
parentdev-cpp/asio: drop old (diff)
downloadgentoo-cd1a85e41bd9b3a3068fb6dc2f3fc350d1b88167.tar.gz
gentoo-cd1a85e41bd9b3a3068fb6dc2f3fc350d1b88167.tar.bz2
gentoo-cd1a85e41bd9b3a3068fb6dc2f3fc350d1b88167.zip
dev-cpp/asio: version 1.9.0
Closes: https://github.com/gentoo/gentoo/pull/21577 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.19.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 5a3ae789f30f..0d24276d2142 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,4 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.17.0.tar.bz2 1694631 BLAKE2B 0463355eef1714604290be43247139ea0220c5614c3c280ccf6049b64a2bb920c9eb885cf5f00c7e007caf3b049fe5cd6589dad0cb23cda4994fd31c7ecd8102 SHA512 5978cbf452aff07d6d19a2e641824628f409ab74e2e1a964776dae4c586386149acea56e4c8aa1075b247d2ce566daad640c3bbd15e211df1f73fc7b02964353
DIST asio-1.18.2.tar.bz2 1743146 BLAKE2B 8db47419180095e4f05a63e4f414f33399e44f1dfb36299c70fef8bfef347f25df67ae78abf6b6b051e350b10099ec49e751b129bb1913dadf792e24048233a2 SHA512 ebe659f958b1813c4a843dce94a8f51d3a3b9f8e0237aa0f032009adaf85400b63b04ac8d664c9424397927d34d78206cbc646d921a520ed415c505f086628b1
+DIST asio-1.19.0.tar.bz2 1840674 BLAKE2B 1abfc74356dcc86b07c2599ae5668b18c97fc1da39468aae5d8aff0f8b5826ea55de1c287816f370eac2c42608535ee44afaedc66afd88c84c9ebca665d42be9 SHA512 d9eb232a0165449985f655433de5d1fa2904edb7a241d55897d3e675d9feca9092342cbb0b6a7d84dbc8f3b6c147c62fa8af5536f065b3f77f800841bf443312
diff --git a/dev-cpp/asio/asio-1.19.0.ebuild b/dev-cpp/asio/asio-1.19.0.ebuild
new file mode 100644
index 000000000000..82d648ca221a
--- /dev/null
+++ b/dev-cpp/asio/asio-1.19.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples ssl test"
+RESTRICT="!test? ( test )"
+# test searches for libssl during ./configure, and REQUIRED_USE is easier than
+# patching configure to not search for it with USE=-ssl
+REQUIRED_USE="test? ( ssl )"
+
+RDEPEND="dev-libs/boost:=
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}