summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-23 13:01:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-23 13:07:51 +0200
commitd792e9207199064c4b227319344841a617fad005 (patch)
tree55f7e407f523ba9d1c772b9bb9e554ef96ffb34a /dev-cpp
parentapp-pda/pilot-link: Remove old (diff)
downloadgentoo-d792e9207199064c4b227319344841a617fad005.tar.gz
gentoo-d792e9207199064c4b227319344841a617fad005.tar.bz2
gentoo-d792e9207199064c4b227319344841a617fad005.zip
dev-cpp/ctemplate: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/Manifest1
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild77
-rw-r--r--dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch29
3 files changed, 0 insertions, 107 deletions
diff --git a/dev-cpp/ctemplate/Manifest b/dev-cpp/ctemplate/Manifest
index 184cb62669cb..2f6b74dd23a9 100644
--- a/dev-cpp/ctemplate/Manifest
+++ b/dev-cpp/ctemplate/Manifest
@@ -1,2 +1 @@
-DIST ctemplate-2.3.tar.bz2 564389 BLAKE2B e0c95ac534eb0b7fdff3e87e08f3b1b8aa735bec8eef05bebcf87a51375cbc93e768a18ba005248edda023869b21679dbadaf3d6462e71666fa5d85b96172851 SHA512 546645389a8bfed59686b62b43cb7d53714ac98e1b75311c217bb0f3b6201d5d486766b1ce7e35bf15032372e45c36b27008f54085bd0c9ef0dd0b7e04b8e3f5
DIST ctemplate-2.4.tar.gz 391923 BLAKE2B 96b585ed6ca323fc461857e1f2f381e0ca5c229d8c6039c24efcf34fb9ddf45cc36bef141af337e591e1cdd95ca510ea5ba1e539554322c578c25187b1906195 SHA512 4955489e7327bce18802d50fd9dfc8ac12af685e556d1c9d0eb2b7a2f4a9b6086e30be8388d694ec8912623738973d0c76e9ca97196c63c139ee5b468d4858b7
diff --git a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild b/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
deleted file mode 100644
index 36ba44df7ed2..000000000000
--- a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools elisp-common python-any-r1
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="https://github.com/olafvdspek/ctemplate"
-SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs test"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-RDEPEND="
- emacs? ( >=app-editors/emacs-23.1:* )
- vim-syntax? ( >=app-editors/vim-core-7 )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-# Some tests are broken in 2.3
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.3-fix-build-system.patch )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use emacs; then
- elisp-compile contrib/tpl-mode.el
- fi
-}
-
-src_install() {
- default
- if ! use doc; then
- rm -r "${ED%/}"/usr/share/doc/${PF}/html || die
- fi
-
- if use vim-syntax; then
- cd "${S}/contrib" || die
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/.
- fi
-
- if use emacs; then
- cd "${S}/contrib" || die
- elisp-install ${PN} tpl-mode.el tpl-mode.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch b/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch
deleted file mode 100644
index 4178f5ed3655..000000000000
--- a/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-* Do not override $(docdir) as userflag in the GNU conventions
-* Only build tests programs when running 'make check'
-
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -54,12 +54,11 @@
- src/ctemplate/per_expand_data.h.in \
- src/ctemplate/str_ref.h.in
-
--docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
- ## This is for HTML and other documentation you want to install.
- ## Add your documentation files (in doc/) in addition to these
- ## top-level boilerplate files. Also add a TODO file if you have one.
--dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
-- doc/designstyle.css doc/index.html \
-+dist_doc_DATA = AUTHORS ChangeLog NEWS README README_windows.txt
-+dist_html_DATA = doc/designstyle.css doc/index.html \
- doc/howto.html doc/guide.html doc/reference.html \
- doc/tips.html doc/example.html doc/auto_escape.html \
- doc/xss_resources.html
-@@ -452,7 +451,7 @@
-
- ## This should always include $(TESTS), but may also include other
- ## binaries that you compile but don't want automatically installed.
--noinst_PROGRAMS = $(TESTS)
-+check_PROGRAMS = $(TESTS)
-
- rpm: dist-gzip packages/rpm.sh packages/rpm/rpm.spec
- @cd packages && ./rpm.sh ${PACKAGE} ${VERSION}