summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-07-26 14:22:31 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:18 +0300
commitfbf5279239f798f8170d43c47e16b9d06ce44127 (patch)
tree7afbef6b71356f9e52fe931783d4c6b8c284aaa1 /dev-cpp
parentdev-games/irrlicht: Add patch to remove sys/sysctl.h include (diff)
downloadgentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.tar.gz
gentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.tar.bz2
gentoo-fbf5279239f798f8170d43c47e16b9d06ce44127.zip
dev-cpp/benchmark: New package
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/Manifest1
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.1.ebuild26
-rw-r--r--dev-cpp/benchmark/metadata.xml17
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/Manifest b/dev-cpp/benchmark/Manifest
new file mode 100644
index 000000000000..1bc43e7976a0
--- /dev/null
+++ b/dev-cpp/benchmark/Manifest
@@ -0,0 +1 @@
+DIST benchmark-1.5.1.tar.gz 154896 BLAKE2B cb8d74b3e6662e35ea12809d8b62d1e3a6849668840c84697e7f4b2d29eaf68688bb1cda6f43c170e70366de88a93af79bb709d55dfc8d79140c11a31855a46b SHA512 1e8782ab6846b8b29c5eea41ed1ba19dd92a46a135cf74acdc588e2cd5ef05581c644d20fc0d6403456d65417538e1db80109ae87989601298b2fc56ae3c3161
diff --git a/dev-cpp/benchmark/benchmark-1.5.1.ebuild b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
new file mode 100644
index 000000000000..c64fe45b19ae
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/benchmark/metadata.xml b/dev-cpp/benchmark/metadata.xml
new file mode 100644
index 000000000000..49126cc81f10
--- /dev/null
+++ b/dev-cpp/benchmark/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/google/benchmark/issues</bugs-to>
+ <doc lang="en">https://github.com/google/benchmark/blob/master/docs/</doc>
+ <remote-id type="github">google/benchmark</remote-id>
+ </upstream>
+</pkgmetadata>