summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-10-04 08:19:11 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-10-04 08:20:50 +0200
commitf4d743739ced715fba01e9b99899602f740ee4be (patch)
tree877c5c40838db7587feb9c228da515f8e317e128 /dev-db/apgdiff
parentdev-ruby/sanitize: add 6.0.0 (diff)
downloadgentoo-f4d743739ced715fba01e9b99899602f740ee4be.tar.gz
gentoo-f4d743739ced715fba01e9b99899602f740ee4be.tar.bz2
gentoo-f4d743739ced715fba01e9b99899602f740ee4be.zip
dev-db/apgdiff: bump to 2.7.0
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-db/apgdiff')
-rw-r--r--dev-db/apgdiff/Manifest1
-rw-r--r--dev-db/apgdiff/apgdiff-2.7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-db/apgdiff/Manifest b/dev-db/apgdiff/Manifest
index e2443ad6aba5..8d4eb5dcbdbe 100644
--- a/dev-db/apgdiff/Manifest
+++ b/dev-db/apgdiff/Manifest
@@ -1 +1,2 @@
DIST apgdiff-2.4-src.zip 227714 BLAKE2B 1c62c94592b28a7caf5a56f4ef4206cc2655f2da278d5a71e165f409587d1573dd44b62261817f0b994ed95a398555190dee6a2873fe493f695e91c6cf9dd22c SHA512 f37e0f86ff8a8bc53a43cac1748ab3a2c96ab6c972b37ee63f281ee397b31a7b48986cbc963d89ea773f1bb7b10b798de74a4c88a03f2db7672501b93355261b
+DIST apgdiff-2.7.0-sources.tar.gz 365759 BLAKE2B 6a43bea29fa77a6a07b8599b150769e42480e656d7930faf56dd5db89a2281e10baee596e78d245411879ca99e143d3ebfb6144ea68b5d2f56f7f939004897dc SHA512 db52bcf5af78339ab08cd6a5225d7df9d55cf4eb1bcefaf9e9b12f8ac06f7babb2261ac92b7aa49a6f43a39f9e7894f4dea88b1b794f0a87681ab872c5d1d430
diff --git a/dev-db/apgdiff/apgdiff-2.7.0.ebuild b/dev-db/apgdiff/apgdiff-2.7.0.ebuild
new file mode 100644
index 000000000000..cea00c1a158a
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fordfrog/apgdiff/archive/refs/tags/release_2.7.0.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild apgdiff-2.7.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="cz.startnet:apgdiff:2.7.0"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://www.apgdiff.com/"
+SRC_URI="https://github.com/fordfrog/${PN}/archive/refs/tags/release_${PV}.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4
+# test? org.hamcrest:hamcrest-all:1.3 -> !!!artifactId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+ test? (
+ dev-java/hamcrest-core:0
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${PN}-release_${PV}"
+
+JAVA_LAUNCHER_FILENAME="${PN}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_MAIN_CLASS="cz.startnet.utils.pgdiff.Main"
+JAVA_RESOURCE_DIRS=(
+ "src/main/resources"
+)
+
+JAVA_TEST_GENTOO_CLASSPATH="hamcrest-core,junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)