summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-12-02 06:56:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-12-02 06:56:27 +0000
commit18fec8580b363f15a0bd951ec6b170b0d8960eb2 (patch)
tree1a33215c47554c028ff657ff414fb876bddec9bb /dev-db/barman/barman-3.2.0.ebuild
parentdev-util/tree-sitter-cli: Keyword 0.20.7 s390, #883941 (diff)
downloadgentoo-18fec8580b363f15a0bd951ec6b170b0d8960eb2.tar.gz
gentoo-18fec8580b363f15a0bd951ec6b170b0d8960eb2.tar.bz2
gentoo-18fec8580b363f15a0bd951ec6b170b0d8960eb2.zip
dev-db/barman: add 3.2.0
Closes: https://bugs.gentoo.org/878921 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/barman/barman-3.2.0.ebuild')
-rw-r--r--dev-db/barman/barman-3.2.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/barman/barman-3.2.0.ebuild b/dev-db/barman/barman-3.2.0.ebuild
new file mode 100644
index 000000000000..08998d1bf9e6
--- /dev/null
+++ b/dev-db/barman/barman-3.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+RESTRICT="test" # missing azure sdk
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}