summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-11 17:00:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-11 17:00:54 +0000
commit0d5526b00e3c23b2a10f5de5fd667fee666a872b (patch)
tree6c777c1d6c8c4ecf94c7398e760aca88fdf1858b /dev-db/citus/citus-10.0.2.ebuild
parentapp-portage/pfl: Mark pfl ALLARCHES. (diff)
downloadgentoo-0d5526b00e3c23b2a10f5de5fd667fee666a872b.tar.gz
gentoo-0d5526b00e3c23b2a10f5de5fd667fee666a872b.tar.bz2
gentoo-0d5526b00e3c23b2a10f5de5fd667fee666a872b.zip
dev-db/citus: Bump to 10.0.2
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/citus/citus-10.0.2.ebuild')
-rw-r--r--dev-db/citus/citus-10.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/citus/citus-10.0.2.ebuild b/dev-db/citus/citus-10.0.2.ebuild
new file mode 100644
index 000000000000..4bb39ab5f008
--- /dev/null
+++ b/dev-db/citus/citus-10.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 13 )
+
+inherit postgres-multi
+
+DESCRIPTION="Open-source postgresql extension for clustering/multi-node setups"
+HOMEPAGE="https://www.citusdata.com/"
+SRC_URI="https://github.com/citusdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="POSTGRESQL AGPL-3"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/lz4
+ app-arch/zstd
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ postgres-multi_foreach econf
+}