summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-02 09:13:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-02 09:13:49 +0000
commitb73703abea961524c21a8d566206578bf7dec849 (patch)
tree5484003c6c6db9504a435cc43469ae5643a504ca /dev-db/citus/citus-9.5.4.ebuild
parentdev-db/postgis: Bump (diff)
downloadgentoo-b73703abea961524c21a8d566206578bf7dec849.tar.gz
gentoo-b73703abea961524c21a8d566206578bf7dec849.tar.bz2
gentoo-b73703abea961524c21a8d566206578bf7dec849.zip
dev-db/citus: Bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/citus/citus-9.5.4.ebuild')
-rw-r--r--dev-db/citus/citus-9.5.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/citus/citus-9.5.4.ebuild b/dev-db/citus/citus-9.5.4.ebuild
new file mode 100644
index 000000000000..4bb39ab5f008
--- /dev/null
+++ b/dev-db/citus/citus-9.5.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 13 )
+
+inherit postgres-multi
+
+DESCRIPTION="Open-source postgresql extension for clustering/multi-node setups"
+HOMEPAGE="https://www.citusdata.com/"
+SRC_URI="https://github.com/citusdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="POSTGRESQL AGPL-3"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/lz4
+ app-arch/zstd
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ postgres-multi_foreach econf
+}