summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeaaru <geaaru@gmail.com>2017-12-07 09:54:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-07 10:12:26 +0100
commit5084338185ba601335cbc09166677c9b203b5933 (patch)
treeadb4483a975b6bf65ab9c4ded5421c825b06c956 /dev-db/cpp-driver/cpp-driver-2.8.0.ebuild
parentprofiles: mask dev-vcs/qct for removal (diff)
downloadgentoo-5084338185ba601335cbc09166677c9b203b5933.tar.gz
gentoo-5084338185ba601335cbc09166677c9b203b5933.tar.bz2
gentoo-5084338185ba601335cbc09166677c9b203b5933.zip
dev-db/cpp-driver: 2.8.0 version bump, bug #639116
Package-Manager: Portage-2.3.13, Repoman-2.3.4 Closes: https://bugs.gentoo.org/639116 Closes: https://github.com/gentoo/gentoo/pull/6446
Diffstat (limited to 'dev-db/cpp-driver/cpp-driver-2.8.0.ebuild')
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/cpp-driver-2.8.0.ebuild b/dev-db/cpp-driver/cpp-driver-2.8.0.ebuild
new file mode 100644
index 000000000000..840881be4575
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="http://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/libuv:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}