summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeaaru <geaaru@gmail.com>2018-02-17 15:20:09 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-18 18:15:08 +0100
commit65a4ed82ab28f9adcc7ccd409b1ae7fc1f8a041e (patch)
tree68176e6ff1e7519a1f5eb8913cf41097ed5a9dcc /dev-db/cpp-driver/cpp-driver-2.8.1.ebuild
parentsys-kernel/ck-sources: version bump to 4.14.20. (diff)
downloadgentoo-65a4ed82ab28f9adcc7ccd409b1ae7fc1f8a041e.tar.gz
gentoo-65a4ed82ab28f9adcc7ccd409b1ae7fc1f8a041e.tar.bz2
gentoo-65a4ed82ab28f9adcc7ccd409b1ae7fc1f8a041e.zip
dev-db/cpp-driver: version bump to 2.8.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://bugs.gentoo.org/644222 Closes: https://github.com/gentoo/gentoo/pull/7211
Diffstat (limited to 'dev-db/cpp-driver/cpp-driver-2.8.1.ebuild')
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.8.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/cpp-driver-2.8.1.ebuild b/dev-db/cpp-driver/cpp-driver-2.8.1.ebuild
new file mode 100644
index 000000000000..454caab7dba4
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="http://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/libuv:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}