summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:11 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:11 +0100
commit78225138652181a3ab19f79a6a220c03c34dba1c (patch)
treefb15412c338303ac1f59df319246563730ee2ea0 /dev-db/etcd
parentapp-misc/elasticsearch: migrate to tmpfiles.eclass (diff)
downloadgentoo-78225138652181a3ab19f79a6a220c03c34dba1c.tar.gz
gentoo-78225138652181a3ab19f79a6a220c03c34dba1c.tar.bz2
gentoo-78225138652181a3ab19f79a6a220c03c34dba1c.zip
dev-db/etcd: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/etcd')
-rw-r--r--dev-db/etcd/etcd-3.3.23.ebuild6
-rw-r--r--dev-db/etcd/etcd-3.3.24.ebuild6
-rw-r--r--dev-db/etcd/etcd-3.4.10.ebuild6
-rw-r--r--dev-db/etcd/etcd-3.4.11.ebuild6
-rw-r--r--dev-db/etcd/etcd-3.4.14.ebuild6
5 files changed, 15 insertions, 15 deletions
diff --git a/dev-db/etcd/etcd-3.3.23.ebuild b/dev-db/etcd/etcd-3.3.23.ebuild
index d767c318c0c5..8381d1a4fae4 100644
--- a/dev-db/etcd/etcd-3.3.23.ebuild
+++ b/dev-db/etcd/etcd-3.3.23.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module systemd
+inherit go-module systemd tmpfiles
GIT_COMMIT=4873f5516
MY_PV="${PV/_rc/-rc.}"
@@ -68,7 +68,7 @@ src_install() {
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
diff --git a/dev-db/etcd/etcd-3.3.24.ebuild b/dev-db/etcd/etcd-3.3.24.ebuild
index ebb677c1e00e..d42802d3d244 100644
--- a/dev-db/etcd/etcd-3.3.24.ebuild
+++ b/dev-db/etcd/etcd-3.3.24.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module systemd
+inherit go-module systemd tmpfiles
GIT_COMMIT=bdd57848d
MY_PV="${PV/_rc/-rc.}"
@@ -61,7 +61,7 @@ src_install() {
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
diff --git a/dev-db/etcd/etcd-3.4.10.ebuild b/dev-db/etcd/etcd-3.4.10.ebuild
index 55d46653132b..4cc5cd41c5e2 100644
--- a/dev-db/etcd/etcd-3.4.10.ebuild
+++ b/dev-db/etcd/etcd-3.4.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module systemd
+inherit go-module systemd tmpfiles
GIT_COMMIT=18dfb9cca
MY_PV="${PV/_rc/-rc.}"
@@ -61,7 +61,7 @@ src_install() {
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
diff --git a/dev-db/etcd/etcd-3.4.11.ebuild b/dev-db/etcd/etcd-3.4.11.ebuild
index 0c3cc8f2f4b1..bb9e9a16f55c 100644
--- a/dev-db/etcd/etcd-3.4.11.ebuild
+++ b/dev-db/etcd/etcd-3.4.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module systemd
+inherit go-module systemd tmpfiles
GIT_COMMIT=e71e0c5c8
MY_PV="${PV/_rc/-rc.}"
@@ -61,7 +61,7 @@ src_install() {
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
diff --git a/dev-db/etcd/etcd-3.4.14.ebuild b/dev-db/etcd/etcd-3.4.14.ebuild
index 39f5321f2333..63f03f9e8d4f 100644
--- a/dev-db/etcd/etcd-3.4.14.ebuild
+++ b/dev-db/etcd/etcd-3.4.14.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module systemd
+inherit go-module systemd tmpfiles
GIT_COMMIT=8a03d2e96
MY_PV="${PV/_rc/-rc.}"
@@ -290,7 +290,7 @@ src_install() {
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d