summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-10 09:26:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-10 09:28:13 +0200
commit98e19780edffa7042271bf5931504bd06050eb1c (patch)
treecb059c28d9d972d13fdd67f199e8a9bc31ebcd37 /dev-db/etcd
parentnet-libs/nodejs: ${ED} missing trailing slash on line: 143 (diff)
downloadgentoo-98e19780edffa7042271bf5931504bd06050eb1c.tar.gz
gentoo-98e19780edffa7042271bf5931504bd06050eb1c.tar.bz2
gentoo-98e19780edffa7042271bf5931504bd06050eb1c.zip
dev-db/etcd: Version bump to 3.3.16
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-db/etcd')
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.3.16.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index b2c7da664819..d34fc9286819 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,2 +1,3 @@
DIST etcd-3.3.15.tar.gz 6271373 BLAKE2B 85786a2a4acaf144f80461a56775b8c91164e8f0c0034ef0741d98383ac400720ca69b855588a076dc174364330c0e12df73a36570983138e33a32cdbe69e22f SHA512 9fbc02c4aacb000335d558e9c5d4df672194d1b1b8511918efa35a6123bcd7f1a06ecc527f7ff01af7c7f0e818b4809918e640fd596ec51898bf511849f0a2c5
+DIST etcd-3.3.16.tar.gz 15846502 BLAKE2B 8804ad2d3c24f7dc98fd1b9f7c5d989addaf0cb614cc2b3aec949cf81cdbcc04afc4257b057a336e90e9c4e5eeb96f5dbc445230b0c611b2dbdba3d0998d171b SHA512 50673bd386700fb89e74599f122084115ab8105949921a8ad75a614d0fd55df4ec5fc909997f6422ae321b33d4b7c2fd2fceb34bd1220ddf7892dee6e7d79ae5
DIST etcd-3.4.1.tar.gz 8931994 BLAKE2B 4cfb8a87082be3323b9adb4290c91c4419b8c8d9b343196af07424f126afda4e702da7fed578d8fcd04d1c2c2e34524fb341734afc9c41d5e43ba103c865b262 SHA512 c5c0cd25ae12e02c162490d46ab726b4a1ab5a027435a884cf61b995d5dc290d58534ec271ed41efd7dd3a30b0bd040f74081d943e32928cce16e56484e3bfc5
diff --git a/dev-db/etcd/etcd-3.3.16.ebuild b/dev-db/etcd/etcd-3.3.16.ebuild
new file mode 100644
index 000000000000..1dc051243676
--- /dev/null
+++ b/dev-db/etcd/etcd-3.3.16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/coreos/etcd"
+GIT_COMMIT="94745a4"
+MY_PV="${PV/_rc/-rc.}"
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/etcd-io/etcd"
+SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+IUSE="doc +server"
+DEPEND=">=dev-lang/go-1.12:="
+RDEPEND="!dev-db/etcdctl"
+
+src_prepare() {
+ default
+ sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
+ -i "${S}"/src/${EGO_PN}/build || die
+ sed -e 's:\(for p in \)shellcheck :\1 :' \
+ -e 's:^ gofmt \\$:\\:' \
+ -e 's:^ govet \\$:\\:' \
+ -i "${S}"/src/${EGO_PN}/test || die
+ # missing ... in args forwarded to print-like function
+ sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
+ -i "${S}"/src/${EGO_PN}/raft/logger.go || die
+}
+
+pkg_setup() {
+ if use server; then
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+ fi
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #651934
+ export GOPATH=${S}
+ pushd src/${EGO_PN} || die
+ GO_BUILD_FLAGS=-v ./build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/etcdctl
+ use doc && dodoc -r Documentation
+ if use server; then
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/etcd
+ dodoc README.md
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 0700 /var/lib/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+ fi
+ popd || die
+}
+
+src_test() {
+ pushd src/${EGO_PN} || die
+ ./test || die
+ popd || die
+}