summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/etcdctl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/etcdctl')
-rw-r--r--dev-db/etcdctl/Manifest1
-rw-r--r--dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild34
-rw-r--r--dev-db/etcdctl/etcdctl-0.4.6.ebuild34
-rw-r--r--dev-db/etcdctl/metadata.xml13
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-db/etcdctl/Manifest b/dev-db/etcdctl/Manifest
new file mode 100644
index 000000000000..da679aceb949
--- /dev/null
+++ b/dev-db/etcdctl/Manifest
@@ -0,0 +1 @@
+DIST etcdctl-0.4.6.zip 62437 SHA256 b57c463bfc65114b3f78406409edf693af6f79fa3d2937470081355d629121a7 SHA512 b47c3a0e2071e0352226e91f344839f1dfcd75dc8d11ca6b73c33a0570aabe94f557c3ed79ec9da9e0005656d8da49468c3df4a82df61c823cb1902b6e09bddd WHIRLPOOL a630d2d21956221363c292c37dd996a6fc0986eced0a58ec0703eabcd10b36106dd53f5a708b4aedb8158330f70e853c1228d611564d56b56838aa9d4a9342b4
diff --git a/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild b/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..8fb38cbcca19
--- /dev/null
+++ b/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KEYWORDS="~amd64"
+DESCRIPTION="A simple command line client for etcd"
+HOMEPAGE="https://github.com/coreos/etcdctl/"
+SRC_URI="https://github.com/coreos/etcdctl/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=dev-lang/go-1.2:="
+RDEPEND=""
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+src_test() {
+ ./test || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ use examples && dodoc -r examples
+}
diff --git a/dev-db/etcdctl/etcdctl-0.4.6.ebuild b/dev-db/etcdctl/etcdctl-0.4.6.ebuild
new file mode 100644
index 000000000000..45973eade0d4
--- /dev/null
+++ b/dev-db/etcdctl/etcdctl-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KEYWORDS="~amd64"
+DESCRIPTION="A simple command line client for etcd"
+HOMEPAGE="https://github.com/coreos/etcdctl/"
+SRC_URI="https://github.com/coreos/etcdctl/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=dev-lang/go-1.2"
+RDEPEND=""
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+src_test() {
+ ./test || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ use examples && dodoc -r examples
+}
diff --git a/dev-db/etcdctl/metadata.xml b/dev-db/etcdctl/metadata.xml
new file mode 100644
index 000000000000..928c51782818
--- /dev/null
+++ b/dev-db/etcdctl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/coreos/etcdctl/issues</bugs-to>
+ <changelog>https://github.com/coreos/etcdctl/commits/master</changelog>
+ <doc>https://github.com/coreos/etcdctl/blob/master/README.md</doc>
+ <remote-id type="github">coreos/etcdctl</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>