summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-07-15 14:31:46 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-07-15 14:31:46 -0700
commitb6fb82e3b56b51e079ef0d6f9a12cde5d5d66bba (patch)
treefbc37e14d2e7d46df11956065464384cef07cc3c /dev-db/influxdb/influxdb-1.8.0-r1.ebuild
parentdev-db/influxdb: cleanup new init script (diff)
downloadgentoo-b6fb82e3b56b51e079ef0d6f9a12cde5d5d66bba.tar.gz
gentoo-b6fb82e3b56b51e079ef0d6f9a12cde5d5d66bba.tar.bz2
gentoo-b6fb82e3b56b51e079ef0d6f9a12cde5d5d66bba.zip
dev-db/influxdb: merge improvements from seperate 1.8.0 work to -r1
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-db/influxdb/influxdb-1.8.0-r1.ebuild')
-rw-r--r--dev-db/influxdb/influxdb-1.8.0-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-db/influxdb/influxdb-1.8.0-r1.ebuild b/dev-db/influxdb/influxdb-1.8.0-r1.ebuild
index 9879d5f13bb1..658437482efb 100644
--- a/dev-db/influxdb/influxdb-1.8.0-r1.ebuild
+++ b/dev-db/influxdb/influxdb-1.8.0-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DESCRIPTION="Scalable datastore for metrics, events, and real-time analytics"
HOMEPAGE="https://www.influxdata.com"
-inherit go-module systemd user
+inherit go-module systemd
EGO_PN="github.com/influxdata/${PN}"
EGO_SUM=(
@@ -461,15 +461,15 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"
-DEPEND="doc? (
+BDEPEND="doc? (
>=app-text/asciidoc-8.6.10
app-text/xmlto
)"
-
-pkg_setup() {
- enewgroup influxdb
- enewuser influxdb -1 -1 /var/lib/influxdb influxdb
-}
+COMMON_DEPEND="
+ acct-group/influxdb
+ acct-user/influxdb"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
src_compile() {
set -- env GOBIN="${S}/bin/" go install -a -installsuffix cgo \
@@ -477,7 +477,7 @@ src_compile() {
-v -work -x ./...
echo "$@"
"$@" || die "compile failed"
- use doc && cd man && emake build
+ use doc && emake -C man build
}
src_install() {