summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-28 01:11:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-28 03:07:01 +0100
commit81bc57fe964c6e4baf3999bd346b89ba0d83d571 (patch)
treef45788467d13752368380c0ba5c89d69cf4a17a3 /dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild
parentdev-util/jenkins-bin: bump to v2.153 (diff)
downloadgentoo-81bc57fe964c6e4baf3999bd346b89ba0d83d571.tar.gz
gentoo-81bc57fe964c6e4baf3999bd346b89ba0d83d571.tar.bz2
gentoo-81bc57fe964c6e4baf3999bd346b89ba0d83d571.zip
dev-db/kyotocabinet: bump to v1.2.77
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild')
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild
new file mode 100644
index 000000000000..36ee56423060
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.77.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="https://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples +lzma +lzo static-libs"
+
+DEPEND="sys-libs/zlib[static-libs?]
+ lzma? ( app-arch/xz-utils:=[static-libs?] )
+ lzo? ( dev-libs/lzo:=[static-libs?] )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/fix_configure-1.2.62.patch
+ "${FILESDIR}"/${PN}-1.2.76-configure-8-byte-atomics.patch
+ "${FILESDIR}"/${PN}-1.2.76-flags.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "/DOCDIR/d" Makefile.in || die
+ tc-export AR
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # We need to set LD_LIBRARY_PATH which will be assigned to RUNENV later
+ # used by test suite
+ LD_LIBRARY_PATH=. \
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ $(use_enable lzma) \
+ $(use_enable lzo)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/*
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/*
+ fi
+}