summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/libzdb/libzdb-2.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/libzdb/libzdb-2.12.ebuild')
-rw-r--r--dev-db/libzdb/libzdb-2.12.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-db/libzdb/libzdb-2.12.ebuild b/dev-db/libzdb/libzdb-2.12.ebuild
new file mode 100644
index 000000000000..d4318ff57c5b
--- /dev/null
+++ b/dev-db/libzdb/libzdb-2.12.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="http://www.tildeslash.com/libzdb/"
+SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc mysql postgres +sqlite ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RESTRICT=test
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ if [[ $(gcc-version) < 4.1 ]];then
+ myconf="${myconf} --disable-protected"
+ else
+ myconf="${myconf} --enable-protected"
+ fi
+
+ if use sqlite; then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default_src_compile
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ dohtml -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}